summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gwget/ChangeLog8
-rw-r--r--net-misc/gwget/Manifest15
-rw-r--r--net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch29
-rw-r--r--net-misc/gwget/gwget-1.0.4.ebuild11
4 files changed, 46 insertions, 17 deletions
diff --git a/net-misc/gwget/ChangeLog b/net-misc/gwget/ChangeLog
index 82c5d997e4d4..8ef9f831bd5f 100644
--- a/net-misc/gwget/ChangeLog
+++ b/net-misc/gwget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/gwget
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.23 2010/10/14 18:37:06 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.24 2011/02/05 16:41:11 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> gwget-1.0.4.ebuild,
+ +files/gwget-1.0.4-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
14 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org> -gwget-0.99.ebuild,
-gwget-1.0.2.ebuild, -gwget-1.0.3.ebuild:
diff --git a/net-misc/gwget/Manifest b/net-misc/gwget/Manifest
index a524b02eb9db..4adcacefefde 100644
--- a/net-misc/gwget/Manifest
+++ b/net-misc/gwget/Manifest
@@ -1,14 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+AUX gwget-1.0.4-libnotify-0.7.patch 911 RMD160 fec3ec249816827abf6483b5b3fa8b9f58be6900 SHA1 fe3760cf6be3d167f0cf00bf73d3db852a833cb2 SHA256 47c89f4331d20c841d11ed732288cfb68482a80134d72241a88f1843a200dec0
DIST gwget-1.0.4.tar.bz2 444843 RMD160 461bc7823aaf5043def1dbf15b07fb098216086d SHA1 d2cc6eafb23488798939f99f6aad4e1a87f1d7c0 SHA256 a65b2b2b3befb6cf34a697a13111b35498a6d63f9a9b048a22b8654f35ef643f
-EBUILD gwget-1.0.4.ebuild 1217 RMD160 a1085a25a04fd5145b49e4607c799c63176b5571 SHA1 da81992fd5c361a2410912eb8cfb18f5b446de7a SHA256 97c6a873731e5cfd8abbe8f282c80e97264b8b39a209b44e790df64c273508db
-MISC ChangeLog 5028 RMD160 371135e91ad5a34fb114736dbe3b5e35221e2ba0 SHA1 a932ec777f7e3f7fdf279f1619435abe7621b0a6 SHA256 85978a345101e59bb8e41a9726f8f622dc87dfaee68da2b818f5d49557713891
+EBUILD gwget-1.0.4.ebuild 1313 RMD160 00dd46615f8f773dec035bf13486552e8d180aaf SHA1 bbed50a233ec10e159656c85374f16ec6d7bf3de SHA256 6d5d55fef5fda9a86b023e9dd24415f5b221cb4fd0a1ba61c855098b25d96889
+MISC ChangeLog 5198 RMD160 69e0ac1ec322b604017f6bfcbadf00ffdecf6203 SHA1 aace2bd6a62a3ef505417e9b10707d77fe00bb0f SHA256 feb8353b7713795d35b7b643130ba8e86caeaed054429d523f448b8613e437ff
MISC metadata.xml 1146 RMD160 7ff1842eafef7cd12f9c42cc2533faa69d26a1aa SHA1 0810625057df6d5cf332efb99ebb59375132ba73 SHA256 3969ef8156d53645717a708d60b8d0f9509c74bebfab44deefd246b5be375c10
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.16 (GNU/Linux)
-
-iEYEARECAAYFAky3TkgACgkQ1fmVwcYIWAYY0wCg1qyoYDMMw16szqjDbtGp1a69
-yHMAoKGgDlLzBK51oe/OcHHghJnXZ/4n
-=Rg3W
------END PGP SIGNATURE-----
diff --git a/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch b/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..116cf60b9920
--- /dev/null
+++ b/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
@@ -0,0 +1,29 @@
+--- src/systray.c
++++ src/systray.c
+@@ -6,6 +6,12 @@
+ #include "systray.h"
+ #include "main_window_cb.h"
+
++#ifdef HAVE_NOTIFY
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++#endif
++
+ static GdkPixbuf *systray_load_icon (const gchar *filename);
+ static GdkPixbuf *systray_pixbuf_new_from_file(const gchar *filename);
+ static void systray_clicked(GtkStatusIcon *status_icon,guint button,guint activate_time,gpointer user_data);
+@@ -224,7 +230,12 @@
+ if (!notify_is_initted ())
+ if (!notify_init ("gwget"))
+ return;
+- NotifyNotification *notification = notify_notification_new(primary,secondary,icon_name,NULL);
++ NotifyNotification *notification = notify_notification_new(primary,secondary,icon_name
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ ,NULL);
++#endif
+ notify_notification_show(notification,NULL);
+ #endif
+
diff --git a/net-misc/gwget/gwget-1.0.4.ebuild b/net-misc/gwget/gwget-1.0.4.ebuild
index c6c8066de35b..8744fc1af6f9 100644
--- a/net-misc/gwget/gwget-1.0.4.ebuild
+++ b/net-misc/gwget/gwget-1.0.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.4.ebuild,v 1.4 2010/10/14 17:02:29 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.4.ebuild,v 1.5 2011/02/05 16:41:11 ssuominen Exp $
EAPI="2"
GCONF_DEBUG="no"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="GTK2 WGet Frontend"
HOMEPAGE="http://gnome.org/projects/gwget/"
@@ -40,6 +40,11 @@ pkg_setup() {
--disable-schemas-install"
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ gnome2_src_prepare
+}
+
src_install() {
gnome2_src_install