summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog8
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r10.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index c6c76b1b5953..70cfce3227a2 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.83 2010/05/30 22:29:59 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.84 2010/06/12 08:59:47 nelchael Exp $
+
+*tuxonice-sources-2.6.32-r10 (12 Jun 2010)
+
+ 12 Jun 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +tuxonice-sources-2.6.32-r10.ebuild:
+ Revision bump for new genpatches.
*tuxonice-sources-2.6.32-r9 (30 May 2010)
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r10.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r10.ebuild
new file mode 100644
index 000000000000..9a4a652635c0
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r10.ebuild,v 1.1 2010/06/12 08:59:47 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="13"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~dsd/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.1"
+TUXONICE_TARGET="2.6.32"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch-${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+
+TUXONICE_URI="http://www.tuxonice.net/downloads/all/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ >=sys-power/hibernate-script-2.0"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}