summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/Manifest10
-rw-r--r--sys-libs/readline/files/digest-readline-5.11
-rw-r--r--sys-libs/readline/readline-5.1.ebuild81
4 files changed, 94 insertions, 5 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 3a231bf113cd..8ed7452a85d6 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.50 2005/09/10 17:07:07 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.51 2005/12/10 21:56:44 vapier Exp $
+
+*readline-5.1 (10 Dec 2005)
+
+ 10 Dec 2005; Mike Frysinger <vapier@gentoo.org> +readline-5.1.ebuild:
+ Version bump.
10 Sep 2005; Kito <kito@gentoo.org> readline-5.0-r2.ebuild:
~ppc-macos keyword. Keep shlibs in /usr/lib and skip gen_usr_ldscript on
diff --git a/sys-libs/readline/Manifest b/sys-libs/readline/Manifest
index 839b7910602d..c84c5b976629 100644
--- a/sys-libs/readline/Manifest
+++ b/sys-libs/readline/Manifest
@@ -1,11 +1,12 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 5f09ffd9d364d7216a30dd17bf343531 ChangeLog 7435
+MD5 0d47a743d9a73411f2f91560468ee399 ChangeLog 7555
MD5 d687545889dacb43e121f4932d99a534 files/bash-3.0-etc-inputrc.patch 1443
MD5 cca21eb56279efff8356d028b1b39dd8 files/digest-readline-4.3-r5 348
MD5 cca21eb56279efff8356d028b1b39dd8 files/digest-readline-4.3-r6 348
MD5 e3ee94eed45baf4ca76736da56d72bad files/digest-readline-5.0-r2 350
+MD5 a0e38a462831e1a0e4e8871bc0c25fea files/digest-readline-5.1 65
MD5 9905e333ead392447a670e0f2374651a files/macos.patch 504
MD5 b908c05444b4c9edbeefa1977345182e files/readline-5.0-darwin.patch 461
MD5 6fea6318a26be7b6186ba83c42fb0d75 files/readline-5.0-del-backspace-policy.patch 1074
@@ -17,10 +18,11 @@ MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 82ac0eae5f66926062b260f7d09de7c0 readline-4.3-r5.ebuild 2764
MD5 e16aefe27f29117c7a4e7be342e920b4 readline-4.3-r6.ebuild 3090
MD5 d33ebebef248a79c288c6b1dce06b0ee readline-5.0-r2.ebuild 2778
+MD5 4f7b9118507236b23f88e076a067e716 readline-5.1.ebuild 2367
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDi9V+gIKl8Uu19MoRAsUYAJ9ASZjBCv9bDWkbplBCNpuqMcg/gACfTAFo
-/hKPQmdxAEa/2a3Gb+FaMJg=
-=UwFZ
+iD8DBQFDm0/cgIKl8Uu19MoRAj53AJwISj7W5BXlCqm1iakaP03YBDm03wCeMQt1
+nvc1IVQs5Q7h5SW3EnaaDKE=
+=b/7m
-----END PGP SIGNATURE-----
diff --git a/sys-libs/readline/files/digest-readline-5.1 b/sys-libs/readline/files/digest-readline-5.1
new file mode 100644
index 000000000000..69fda4e3389b
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-5.1
@@ -0,0 +1 @@
+MD5 7ee5a692db88b30ca48927a13fd60e46 readline-5.1.tar.gz 2030276
diff --git a/sys-libs/readline/readline-5.1.ebuild b/sys-libs/readline/readline-5.1.ebuild
new file mode 100644
index 000000000000..505041cb069d
--- /dev/null
+++ b/sys-libs/readline/readline-5.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.1.ebuild,v 1.1 2005/12/10 21:56:44 vapier Exp $
+
+inherit eutils multilib
+
+# Official patches
+PLEVEL=""
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/readline/${P}.tar.gz
+ ${PLEVEL//x/mirror://gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.05b-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd "${S}"
+ for x in ${PLEVEL//x} ; do
+ epatch "${DISTDIR}"/${PN}${PV/\.}-${x}
+ done
+ epatch "${FILESDIR}"/bash-3.0-etc-inputrc.patch
+ epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
+
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+}
+
+src_compile() {
+ # the --libdir= is needed because if lib64 is a directory, it will default
+ # to using that... even if CONF_LIBDIR isnt set or we're using a version
+ # of portage without CONF_LIBDIR support.
+ econf --with-curses --libdir=/usr/$(get_libdir) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodir /$(get_libdir)
+
+ if ! use userland_Darwin ; then
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ chmod a+rx "${D}"/$(get_libdir)/*.so*
+
+ # Bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+ fi
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+
+pkg_preinst() {
+ # Backwards compatibility #29865
+ if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
+ cp -pPR "${ROOT}"/$(get_libdir)/libreadline.so.4* "${D}"/$(get_libdir)/
+ touch "${D}"/$(get_libdir)/libreadline.so.4*
+ fi
+}
+
+pkg_postinst() {
+ if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --soname libreadline.so.4' asap."
+ ewarn "Once you have, you can safely delete /$(get_libdir)/libreadline.so.4*"
+ fi
+}