From 6038899d759d8405488d097058bdc43ab36feca7 Mon Sep 17 00:00:00 2001
From: Donny Davies <woodchip@gentoo.org>
Date: Thu, 30 Jan 2003 00:11:03 +0000
Subject: new testing release + bug fixes

---
 dev-db/mysql/ChangeLog                  |   7 +-
 dev-db/mysql/files/digest-mysql-3.23.55 |   1 +
 dev-db/mysql/files/mysql-4.0.rc6        |   3 +-
 dev-db/mysql/files/mysql.init           |   3 +-
 dev-db/mysql/mysql-3.23.55.ebuild       | 183 ++++++++++++++++++++++++++++++++
 5 files changed, 194 insertions(+), 3 deletions(-)
 create mode 100644 dev-db/mysql/files/digest-mysql-3.23.55
 create mode 100644 dev-db/mysql/mysql-3.23.55.ebuild

(limited to 'dev-db/mysql')

diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 6b1241672f1b..098a154b0a55 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for dev-db/mysql
 # Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.31 2003/01/04 23:07:22 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.32 2003/01/30 00:11:03 woodchip Exp $
+
+*mysql-3.23.55 (29 Jan 2003)
+
+  29 Jan 2003; Donny Davies <woodchip@gentoo.org> : New testing release.
+  Fix #12933, #13429.
 
 *mysql-4.0.7 (04 Jan 2003)
 
diff --git a/dev-db/mysql/files/digest-mysql-3.23.55 b/dev-db/mysql/files/digest-mysql-3.23.55
new file mode 100644
index 000000000000..5ad6284f2acd
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-3.23.55
@@ -0,0 +1 @@
+MD5 259196ddc00c94051dceb9e86574d17e mysql-3.23.55.tar.gz 11328584
diff --git a/dev-db/mysql/files/mysql-4.0.rc6 b/dev-db/mysql/files/mysql-4.0.rc6
index 126a0ee874ea..29b62d422c0a 100644
--- a/dev-db/mysql/files/mysql-4.0.rc6
+++ b/dev-db/mysql/files/mysql-4.0.rc6
@@ -1,10 +1,11 @@
 #!/sbin/runscript
 # Copyright 1999-2002 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql-4.0.rc6,v 1.2 2003/01/04 23:07:22 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql-4.0.rc6,v 1.3 2003/01/30 00:11:03 woodchip Exp $
 
 depend() {
 	need net
+	use dns
 }
 
 checkconfig() {
diff --git a/dev-db/mysql/files/mysql.init b/dev-db/mysql/files/mysql.init
index a87902425650..ae7cddd6811c 100644
--- a/dev-db/mysql/files/mysql.init
+++ b/dev-db/mysql/files/mysql.init
@@ -1,10 +1,11 @@
 #!/sbin/runscript
 # Copyright 1999-2002 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql.init,v 1.2 2002/10/28 07:15:32 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql.init,v 1.3 2003/01/30 00:11:03 woodchip Exp $
 
 depend() {
 	need net
+	use dns
 }
 
 checkconfig() {
diff --git a/dev-db/mysql/mysql-3.23.55.ebuild b/dev-db/mysql/mysql-3.23.55.ebuild
new file mode 100644
index 000000000000..601757051279
--- /dev/null
+++ b/dev-db/mysql/mysql-3.23.55.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.55.ebuild,v 1.1 2003/01/30 00:11:03 woodchip Exp $
+
+# bug #11681; get b0rked code when using -march=k6 with this package.
+inherit flag-o-matic
+replace-flags "-march=k6-3" "-march=i586"
+replace-flags "-march=k6-2" "-march=i586"
+replace-flags "-march=k6" "-march=i586"
+
+SVER=${PV%.*}
+#normal releases:
+SDIR=MySQL-${SVER}
+#for a pre-release:
+#SDIR=MySQL-${SVER}-Pre
+
+DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
+HOMEPAGE="http://www.mysql.com/"
+SRC_URI="ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/${SDIR}/${P}.tar.gz
+	ftp://mysql.valueclick.com/pub/mysql/Downloads/${SDIR}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static readline innodb berkdb tcpd ssl"
+KEYWORDS="~x86 ~sparc ~alpha"
+
+DEPEND="readline? ( >=sys-libs/readline-4.1 )
+	tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+	ssl? ( >=dev-libs/openssl-0.9.6d )
+	>=sys-libs/zlib-1.1.3
+	sys-devel/perl
+	sys-apps/procps"
+
+# HEY!
+# the benchmark stuff in /usr/share/mysql/sql-bench and
+# the /usr/bin/mysql_setpermission script need dev-perl/DBD-mysql.
+# Can't add it here: circ depend.  Emerge it either before or after
+# mysql; easier before, then it pulls in mysql.
+
+src_unpack() {
+	unpack ${A} || die
+	cd ${S} || die
+	# required for qmail-mysql
+	patch -p0 < ${FILESDIR}/mysql-3.23-nisam.h.diff || die
+	# zap startup script messages
+	patch -p1 < ${FILESDIR}/mysql-3.23.52-install-db-sh.diff || die
+	# zap binary distribution stuff
+	patch -p1 < ${FILESDIR}/mysql-3.23-safe-mysqld-sh.diff || die
+	# for correct hardcoded sysconf directory
+	patch -p1 < ${FILESDIR}/mysql-3.23-my-print-defaults.diff || die
+	#patch -p1 < ${FILESDIR}/mysql-3.23.51-tcpd.patch || die
+}
+
+src_compile() {
+	local myconf
+	# The following fix is due to a bug with bdb on sparc's. See: 
+	# http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
+	if use sparc || use sparc64
+	then
+		myconf="${myconf} --without-berkeley-db"
+	else
+		use berkdb && myconf="${myconf} --with-berkeley-db=./bdb" \
+			|| myconf="${myconf} --without-berkeley-db"
+	fi
+	use readline && myconf="${myconf} --with-readline"
+	use readline || myconf="${myconf} --without-readline"
+	use static && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared"
+	use static || myconf="${myconf} --enable-shared --enable-static"
+	use tcpd && myconf="${myconf} --with-libwrap"
+	use tcpd || myconf="${myconf} --without-libwrap"
+	use innodb && myconf="${myconf} --with-innodb"
+	use innodb || myconf="${myconf} --without-innodb"
+	use ssl && myconf="${myconf} --with-vio --with-openssl"
+	use ssl || myconf="${myconf} --without-openssl"
+	[ -n "${DEBUGBUILD}" ] && myconf="${myconf} --with-debug"
+	[ -n "${DEBUGBUILD}" ] || myconf="${myconf} --without-debug"
+
+	# the compiler flags are as per their "official" spec ;-)
+	einfo "myconf is $myconf"
+	CFLAGS="${CFLAGS/-O?/} -O3" \
+	CXXFLAGS="${CXXFLAGS/-O?/} -O3 -felide-constructors -fno-exceptions -fno-rtti" \
+	econf \
+		--libexecdir=/usr/sbin \
+		--sysconfdir=/etc/mysql \
+		--localstatedir=/var/lib/mysql \
+		--with-raid \
+		--with-low-memory \
+		--enable-assembler \
+		--with-charset=latin1 \
+		--enable-local-infile \
+		--with-mysqld-user=mysql \
+		--with-extra-charsets=all \
+		--enable-thread-safe-client \
+		--with-client-ldflags=-lstdc++ \
+		--with-comment="Gentoo Linux ${PF}" \
+		--with-unix-socket-path=/var/run/mysqld/mysqld.sock \
+		${myconf} || die "bad ./configure"
+
+	make || die "compile problem"
+}
+
+src_install() {
+	make install DESTDIR=${D} benchdir_root=/usr/share/mysql || die
+
+	# eeek, not sure whats going on here.. are these needed by anything?
+#	use innodb && insinto /usr/lib/mysql && doins ${WORKDIR}/../libs/*
+
+	# move client libs, install a couple of missing headers
+	mv ${D}/usr/lib/mysql/libmysqlclient*.so* ${D}/usr/lib
+	dosym ../libmysqlclient.so /usr/lib/mysql/libmysqlclient.so
+	dosym ../libmysqlclient_r.so /usr/lib/mysql/libmysqlclient_r.so
+	insinto /usr/include/mysql ; doins include/{my_config.h,my_dir.h}
+
+	# convenience links
+	dosym /usr/bin/mysqlcheck /usr/bin/mysqlanalyze
+	dosym /usr/bin/mysqlcheck /usr/bin/mysqlrepair
+	dosym /usr/bin/mysqlcheck /usr/bin/mysqloptimize
+
+	# while my broom gently sweeps...
+	rm -f ${D}/usr/share/mysql/binary-configure
+	rm -f ${D}/usr/share/mysql/mysql.server
+	rm -f ${D}/usr/share/mysql/make_binary_distribution
+	rm -f ${D}/usr/share/mysql/mi_test_all*
+	rm -f ${D}/usr/share/mysql/mysql-log-rotate
+	rm -f ${D}/usr/share/mysql/mysql*.spec
+	rm -f ${D}/usr/share/mysql/my-*.cnf
+
+	dodoc README COPYING COPYING.LIB MIRRORS \
+		Docs/{manual.ps,manual.txt}
+	dohtml -r Docs/*
+	docinto conf-samples
+	dodoc support-files/my-*.cnf
+
+	insinto /etc/mysql
+	doins ${FILESDIR}/my.cnf scripts/mysqlaccess.conf
+	exeinto /etc/init.d
+	newexe ${FILESDIR}/mysql.init mysql
+}
+
+pkg_config() {
+	if [ ! -d ${ROOT}/var/lib/mysql/mysql ] ; then
+		einfo "Press ENTER to create the mysql database and set proper"
+		einfo "permissions on it, or Control-C to abort now..."
+		read
+		${ROOT}/usr/bin/mysql_install_db #>>/var/log/mysql/mysql.err 2>&1
+	else
+		einfo "Hmm, it appears as though you already have the mysql"
+		einfo "database in place.  If you are having problems trying"
+		einfo "to start mysqld, perhaps you need to manually run"
+		einfo "/usr/bin/mysql_install_db and/or check your config"
+		einfo "file(s) and/or database(s) and/or logfile(s)."
+	fi
+}
+
+pkg_preinst() {
+	if ! groupmod mysql; then
+		groupadd -g 60 mysql || die "problem adding group mysql"
+	fi
+
+	if ! id mysql; then
+		useradd -g mysql -s /dev/null -d /var/lib/mysql -c "mysql" mysql
+		assert "problem adding user mysql"
+	fi
+}
+
+pkg_postinst() {
+	# empty dirs...
+	install -d -m0755 -o mysql -g mysql ${ROOT}/var/lib/mysql
+	install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
+	install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
+
+	# secure the logfiles... does this bother anybody?
+	touch ${ROOT}/var/log/mysql/mysql.{log,err}
+	chown mysql.mysql ${ROOT}/var/log/mysql/mysql.{log,err}
+	chmod 0660 ${ROOT}/var/log/mysql/mysql.{log,err}
+
+	# your friendly public service announcement...
+	einfo
+	einfo "You might want to run:"
+	einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
+	einfo "if this is a new install."
+	einfo
+}
-- 
cgit v1.2.3-65-gdbad