summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-22 02:37:14 +0200
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-22 02:37:14 +0200
commit63ff0508f63b8c41a8283132670035a4c8d2028b (patch)
treeaa9caad3d217344d44bad3219ecf670246772ed2
parentManifest (diff)
downloaddotnet-63ff0508f63b8c41a8283132670035a4c8d2028b.tar.gz
dotnet-63ff0508f63b8c41a8283132670035a4c8d2028b.tar.bz2
dotnet-63ff0508f63b8c41a8283132670035a4c8d2028b.zip
Paint-Mono, bug 269377.
-rw-r--r--media-gfx/paint-mono/Manifest2
-rw-r--r--media-gfx/paint-mono/paint-mono-0.1.63.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/paint-mono/Manifest b/media-gfx/paint-mono/Manifest
new file mode 100644
index 0000000..3b37253
--- /dev/null
+++ b/media-gfx/paint-mono/Manifest
@@ -0,0 +1,2 @@
+DIST paintdotnet-0.1.63.tar.gz 1318570 RMD160 15308f86ba1662c968602948b5a50a736de186cd SHA1 4e902b1bd2f37169f696bdf910e310d586cd8f4a SHA256 32273a51d1643ff6eb28186c732e91f70474ecf796bbba3fbebb3eee7e1b53a5
+EBUILD paint-mono-0.1.63.ebuild 733 RMD160 1dc073bee33297be8538e04415d24ccaf216a2c2 SHA1 efb995072cdc00dba0d376d0e9839a49c18a9538 SHA256 7f9075000550188eb7265a7b811201e59c198fea38c23fd6e5e616b4c54a58c7
diff --git a/media-gfx/paint-mono/paint-mono-0.1.63.ebuild b/media-gfx/paint-mono/paint-mono-0.1.63.ebuild
new file mode 100644
index 0000000..524d03d
--- /dev/null
+++ b/media-gfx/paint-mono/paint-mono-0.1.63.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="An unofficial effort to port Paint.NET 3.0 to Linux using Mono."
+HOMEPAGE="http://code.google.com/p/paint-mono/"
+SRC_URI="http://${PN}.googlecode.com/files/paintdotnet-${PV}.tar.gz"
+
+LICENSE="MIT CCPL-Attribution-NonCommercial-NoDerivs-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-2.4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/paintdotnet-${PV}"
+
+src_configure() {
+ ./configure --prefix=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ mono_multilib_comply
+ sed -i -e 's:usr/local:usr:' "${D}"/usr/$(get_libdir)/pkgconfig/* "${D}"/usr/bin/*
+}