aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-11-10 16:06:37 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-11-10 16:17:44 +0100
commit117ef537aa215850508592a00347779b1655c617 (patch)
treeb7496c8481aec8d0f70c8b9082e3fce533eabb7b /gui-apps
parentgui-apps/nwg-shell-config: add 0.5.50 (diff)
downloadguru-117ef537aa215850508592a00347779b1655c617.tar.gz
guru-117ef537aa215850508592a00347779b1655c617.tar.bz2
guru-117ef537aa215850508592a00347779b1655c617.zip
gui-apps/nwg-shell-config: add 0.5.51
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-shell-config/Manifest1
-rw-r--r--gui-apps/nwg-shell-config/nwg-shell-config-0.5.51.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell-config/Manifest b/gui-apps/nwg-shell-config/Manifest
index 90270d651..6fcf8f681 100644
--- a/gui-apps/nwg-shell-config/Manifest
+++ b/gui-apps/nwg-shell-config/Manifest
@@ -3,3 +3,4 @@ DIST nwg-shell-config-0.5.47.tar.gz 117727 BLAKE2B f7cb52023ee2f375cee7f397f295d
DIST nwg-shell-config-0.5.48.tar.gz 118639 BLAKE2B 67b1e3ef2e0c0eaed5be11008a1115b0040fc9034e1eb75812f799bb83607f5940f394735530ea626b079e7cb02d42e95cead3f2de9c9915361a657711d94524 SHA512 f2c5a88e24122258541086a6a1cea42810caef45cfdccbc1e77e560dcda2a28665099717d39ffdb39085e850f734c0bfe082f5cf60866cb3015c63ae295ef8aa
DIST nwg-shell-config-0.5.49.tar.gz 118676 BLAKE2B 03a6c270751936485f9ba7e7b9f24a4589e09c3b5f6acf2e0dc871d15a68abb52b8f2eeb7d1f536ef5aca2ef2aadbf2449e897d07296beaeb99aae00725d1324 SHA512 c49bae5758d3ca3a0121a787c275dd1ec5cd06404cb29139ee8d021e4dece3014bb36aa17a337c1de14c6e97511f88732c5622674203f1bc02f5d0b783537693
DIST nwg-shell-config-0.5.50.tar.gz 118671 BLAKE2B b2e8cf208fc064f500b6ccf959666d865c98aa4d0c1506fb30ff63463962576933c5324baadf8bbe77f6e9d8171f4fbf3db219fea62b5cc9fd03bd85b2c02c01 SHA512 58fd5e4afc06f085882d8fbde498361cccc82e038153d5a35e17ecbb071927dcb9df508aabd6409e2b2a173ce48b793ae8ccedb7e0a8bf81b8b375122e1fd937
+DIST nwg-shell-config-0.5.51.tar.gz 118572 BLAKE2B ad943797e39cb0840f6005c54e534fdd82ab1da36fd5870e2e75709090e2472def63798b1d9fb921f2675954ed467097a7c32ccb5eb693e1a4618fe6c1c5f7e3 SHA512 e5af9f6d4554516b081f5bfd7fbf5c25f7dd1bc8caa5771657b45af2b4216c67b9d432dd32fb9ae399de67a8cad60564ac16e84a31f2a616d7cafdb876f0226f
diff --git a/gui-apps/nwg-shell-config/nwg-shell-config-0.5.51.ebuild b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.51.ebuild
new file mode 100644
index 000000000..18bb5419f
--- /dev/null
+++ b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.51.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 xdg-utils
+
+DESCRIPTION="nwg-shell configuration utility"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell-config"
+SRC_URI="https://github.com/nwg-piotr/nwg-shell-config/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-apps/nwg-shell
+ sci-geosciences/geopy
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu nwg-shell-config.desktop
+ doicon nwg-shell-config.svg
+ doicon nwg-shell-update.svg
+ doicon nwg-shell-translate.svg
+ doicon nwg-update-noupdate.svg
+ doicon nwg-update-available.svg
+ doicon nwg-update-checking.svg
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}