aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-22 02:09:12 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-22 02:09:28 +0200
commitddb94e3f25373ae8eae84682060e36b6bf108bf0 (patch)
tree3aacde119bf7a09e62c5fa6d21cb78f39b312d5a /sci-mathematics/lean-mathlib
parentdev-lang/lean: fix build type and flags (diff)
downloadguru-ddb94e3f25373ae8eae84682060e36b6bf108bf0.tar.gz
guru-ddb94e3f25373ae8eae84682060e36b6bf108bf0.tar.bz2
guru-ddb94e3f25373ae8eae84682060e36b6bf108bf0.zip
sci-mathematics/lean-mathlib: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sci-mathematics/lean-mathlib')
-rw-r--r--sci-mathematics/lean-mathlib/Manifest1
-rw-r--r--sci-mathematics/lean-mathlib/lean-mathlib-0.1_p20211021.ebuild43
-rw-r--r--sci-mathematics/lean-mathlib/metadata.xml15
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-mathematics/lean-mathlib/Manifest b/sci-mathematics/lean-mathlib/Manifest
new file mode 100644
index 000000000..6d4751f6e
--- /dev/null
+++ b/sci-mathematics/lean-mathlib/Manifest
@@ -0,0 +1 @@
+DIST lean-mathlib-0.1_p20211021.tar.gz 6665360 BLAKE2B 92d7627a095fd8cbc2bbdeccd9321c86badbd36152a034a15d005eadd0507c21aeeb73ecbef8199a267104b5b881ba5b100355e48003c68785205650c4a23876 SHA512 792e8074cba39d1baab87f47af64c49f2a95043c8e9d592f41fe87d8697405c2595933954e1fbf30cb657551e2350fa274e405996d030e47db166cd078a232e4
diff --git a/sci-mathematics/lean-mathlib/lean-mathlib-0.1_p20211021.ebuild b/sci-mathematics/lean-mathlib/lean-mathlib-0.1_p20211021.ebuild
new file mode 100644
index 000000000..5b3bfe7c8
--- /dev/null
+++ b/sci-mathematics/lean-mathlib/lean-mathlib-0.1_p20211021.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT="3c11bd771ef17197a9e9fcd4a3fabfa2804d950c"
+
+DESCRIPTION="Lean mathematical components library"
+HOMEPAGE="https://github.com/leanprover-community/mathlib"
+SRC_URI="https://github.com/leanprover-community/mathlib/archive/${COMMIT}.tar.gz -> ${PF}.tar.gz"
+S="${WORKDIR}/mathlib-${COMMIT}"
+
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-lang/lean-3.34.0"
+DEPEND="
+ ${RDEPEND}
+ sci-mathematics/mathlib-tools
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ leanpkg configure || die
+}
+
+src_compile() {
+ leanpkg build || die
+}
+
+src_install() {
+ dodoc -r docs
+ rm -r docs || die
+ insinto /usr/lib/lean/mathlib
+ doins -r .
+}
+
+src_test() {
+ leanpkg test || die
+}
diff --git a/sci-mathematics/lean-mathlib/metadata.xml b/sci-mathematics/lean-mathlib/metadata.xml
new file mode 100644
index 000000000..3005583c8
--- /dev/null
+++ b/sci-mathematics/lean-mathlib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/leanprover-community/mathlib/issues</bugs-to>
+ <remote-id type="github">leanprover-community/mathlib</remote-id>
+ </upstream>
+</pkgmetadata>