summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-11-26 21:03:11 +0100
committerFabian Groffen <grobian@gentoo.org>2020-11-26 21:03:11 +0100
commit4e754e319d2f3feb553e50ff74a2dda81abf03f0 (patch)
tree52035a8bc1170ce88b25f6cfd9ea53023b382d45
parentsys-devel/gcc-10.1.0-r1: add fix undefined symbols (diff)
downloadprefix-4e754e319d2f3feb553e50ff74a2dda81abf03f0.tar.gz
prefix-4e754e319d2f3feb553e50ff74a2dda81abf03f0.tar.bz2
prefix-4e754e319d2f3feb553e50ff74a2dda81abf03f0.zip
sys-devel/gcc-10.1.0-r1: avoid -lc linkage on Big Sur
Bug: https://bugs.gentoo.org/756160 Package-Manager: Portage-3.0.10-prefix, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--sys-devel/gcc/gcc-10.1.0-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-10.1.0-r1.ebuild b/sys-devel/gcc/gcc-10.1.0-r1.ebuild
index 5199c4b836..99d7996d72 100644
--- a/sys-devel/gcc/gcc-10.1.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-10.1.0-r1.ebuild
@@ -49,7 +49,12 @@ src_prepare() {
eapply -p1 "${FILESDIR}"/${PN}-10.1.0-macos-bigsur.patch
find . -name "configure" | xargs \
sed -i -e '/^\s*10\.\*)/N' \
- -e '/^\s*10\.\*)\s*_lt_dar_allow_undefined/s/10\.\*/10.*|11.*/'
+ -e '/^\s*10\.\*)\s*_lt_dar_allow_undefined/s/10\.\*/10.*|11.*/' || die
+ if [[ ${CHOST} == *-darwin20 ]] ; then
+ # drop -lc, it isn't there (any more?)
+ sed -i -e '/^SHLIB_LC =/s/=.*$/=/' \
+ libgcc/config/t-slibgcc-darwin || die
+ fi
# fix complaint about Authorization Framework
eapply -p1 "${FILESDIR}"/${PN}-10.1.0-darwin-auth-fixincludes.patch