summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/bzip2-1.0.6-r8.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.6-r8.ebuild b/app-arch/bzip2/bzip2-1.0.6-r8.ebuild
index eeb7f85da2..498b5bb32c 100644
--- a/app-arch/bzip2/bzip2-1.0.6-r8.ebuild
+++ b/app-arch/bzip2/bzip2-1.0.6-r8.ebuild
@@ -73,9 +73,24 @@ bemake() {
}
multilib_src_compile() {
- bemake -f "${S}"/Makefile-libbz2_so all
- # Make sure we link against the shared lib #504648
- ln -sf libbz2.so.${PV} libbz2.so
+ local checkopts=
+ case "${CHOST}" in
+ *-darwin*)
+ bemake PREFIX="${EPREFIX}"/usr -f "${S}"/Makefile-libbz2_dylib all
+ # FWIW, #504648 like for .so below
+ ln -sf libbz2.${PV}.dylib libbz2.dylib
+ ;;
+ *-mint*)
+ # do nothing, no shared libraries
+ :
+ ;;
+ *)
+ bemake -f "${S}"/Makefile-libbz2_so all
+ # Make sure we link against the shared lib #504648
+ [[ $(get_libname) != $(get_libname ${PV}) ]] &&
+ ln -sf libbz2$(get_libname ${PV}) libbz2$(get_libname)
+ ;;
+ esac
bemake -f "${S}"/Makefile all LDFLAGS="${LDFLAGS} $(usex static -static '')"
}