aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/rust-mode/rust-mode-9999-r1.ebuild23
-rw-r--r--app-vim/rust-mode/rust-mode-9999-r1.ebuild21
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/rust-mode/rust-mode-9999-r1.ebuild b/app-emacs/rust-mode/rust-mode-9999-r1.ebuild
new file mode 100644
index 0000000..ba78455
--- /dev/null
+++ b/app-emacs/rust-mode/rust-mode-9999-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit elisp git-r3
+
+DESCRIPTION="A major emacs mode for editing Rust source code"
+HOMEPAGE="http://www.rust-lang.org/"
+EGIT_REPO_URI="https://github.com/rust-lang/rust-mode"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
+ !<=dev-lang/rust-0.11.0-r1:0.11
+ !<=dev-lang/rust-999:nightly
+ !<=dev-lang/rust-9999-r2:git
+"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-vim/rust-mode/rust-mode-9999-r1.ebuild b/app-vim/rust-mode/rust-mode-9999-r1.ebuild
new file mode 100644
index 0000000..12dc204
--- /dev/null
+++ b/app-vim/rust-mode/rust-mode-9999-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit vim-plugin git-r3
+
+DESCRIPTION="Rust mode for vim"
+HOMEPAGE="http://www.rust-lang.org/"
+EGIT_REPO_URI="https://github.com/rust-lang/rust.vim"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
+ !<=dev-lang/rust-0.11.0-r1:0.11
+ !<=dev-lang/rust-999:nightly
+ !<=dev-lang/rust-9999-r2:git
+"