summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-06-02 14:06:28 -0400
committerMike Gilbert <floppym@gentoo.org>2022-06-02 14:06:42 -0400
commit0d1936b7d755aad0f04587f067b00f40c51fb1b8 (patch)
treedf140944cd22560ce7e1f56bcf19362a0fb75403
parentmail-client/thunderbird: stabilize 91.10.0 for amd64 (diff)
downloadgentoo-0d1936b7d755aad0f04587f067b00f40c51fb1b8.tar.gz
gentoo-0d1936b7d755aad0f04587f067b00f40c51fb1b8.tar.bz2
gentoo-0d1936b7d755aad0f04587f067b00f40c51fb1b8.zip
dev-util/pkgdev: move docs build to compile phase
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-util/pkgdev/pkgdev-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-util/pkgdev/pkgdev-9999.ebuild b/dev-util/pkgdev/pkgdev-9999.ebuild
index 94052c39603d..33428f032660 100644
--- a/dev-util/pkgdev/pkgdev-9999.ebuild
+++ b/dev-util/pkgdev/pkgdev-9999.ebuild
@@ -44,21 +44,18 @@ RDEPEND+="dev-vcs/git"
distutils_enable_sphinx doc
distutils_enable_tests setup.py
-python_install_all() {
+python_compile_all() {
# We'll generate man pages ourselves
# Revisit when a release is made
# to pregenerate them, making USE=doc
# for generating the real HTML docs only.
- if use doc ; then
- cd doc || die
- emake man
- doman _build/man/*
- fi
-
- cd .. || die
+ use doc && emake -C doc man
# HTML pages only
sphinx_compile_all
+}
+python_install_all() {
+ use doc && doman doc/_build/man/*
distutils-r1_python_install_all
}