summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-06 07:15:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-06 07:51:36 +0100
commit36ac87a8a27e0acd02cadf37faea5853363fd064 (patch)
tree1d6fb98593bfd0ccf1208c2b03271cb41f9d5ff9
parentdev-python/pytest-jupyter: Bump to 0.8.0 (diff)
downloadgentoo-36ac87a8a27e0acd02cadf37faea5853363fd064.tar.gz
gentoo-36ac87a8a27e0acd02cadf37faea5853363fd064.tar.bz2
gentoo-36ac87a8a27e0acd02cadf37faea5853363fd064.zip
dev-python/urwid: Bump to 2.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urwid/Manifest1
-rw-r--r--dev-python/urwid/urwid-2.3.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index 8795fe0eea38..9cf0130b0897 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -1 +1,2 @@
DIST urwid-2.2.3.tar.gz 677723 BLAKE2B 4aeae29e557e0ecbe902b56865feef3b2978263e657f2159194d8334852627ac6ccee82730d6a7e24b8914e5548ca88ac00eeddd7c2a34299d135843a99008fb SHA512 48588d0c819b229bdaaa70bec3a279c3bf232b8520d95e1f45a83bea927244634e91fd47cc161647c2d8155e523543549bc5ed2ccb5eac29843e12515e5dfd22
+DIST urwid-2.3.4.tar.gz 678305 BLAKE2B 1b0de4ae4a18751275de968da9899e934277d8f9ac24cd1363ec9bbef48492f5fc6e00785c75447c8eddba2952fb37689b1e2b7b74a430590020b3aa77979f16 SHA512 e1ed9357b738975c909f847a2f12292cfad1cf824be9d3818ca0de3d1ca5c992ba89d5cea25888db3a8bb6c73a64b94ecb1df0a19d5af7f7b060bd113f93a8dd
diff --git a/dev-python/urwid/urwid-2.3.4.ebuild b/dev-python/urwid/urwid-2.3.4.ebuild
new file mode 100644
index 000000000000..ddf92bfdf600
--- /dev/null
+++ b/dev-python/urwid/urwid-2.3.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Curses-based user interface library for Python"
+HOMEPAGE="
+ https://urwid.org/
+ https://pypi.org/project/urwid/
+ https://github.com/urwid/urwid/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+distutils_enable_tests unittest
+
+python_test() {
+ rm -rf urwid || die
+ eunittest
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Trio event loop" "dev-python/trio"
+}