summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 20:46:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-26 20:54:42 +0200
commit37df2fe6c2c539a419765a2c87d7d358c39b2f02 (patch)
treec286fc2badd9f94c684a90499061bd9fcf43149f
parentdev-python/bottle: Bump to 0.12.20 (diff)
downloadgentoo-37df2fe6c2c539a419765a2c87d7d358c39b2f02.tar.gz
gentoo-37df2fe6c2c539a419765a2c87d7d358c39b2f02.tar.bz2
gentoo-37df2fe6c2c539a419765a2c87d7d358c39b2f02.zip
dev-python/semantic_version: Bump to 2.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/semantic_version/Manifest1
-rw-r--r--dev-python/semantic_version/semantic_version-2.10.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/semantic_version/Manifest b/dev-python/semantic_version/Manifest
index e9b6e3e3b8bb..cec32216cef2 100644
--- a/dev-python/semantic_version/Manifest
+++ b/dev-python/semantic_version/Manifest
@@ -1 +1,2 @@
+DIST semantic_version-2.10.0.tar.gz 52289 BLAKE2B bb26ac31e71974376b40893cf000fe0d85e1e3e4c7c93372f2bfca841a5d760a99ca49d67f80c6e8707e60e313162b786300109f6f8cd1cfaa0001c343bc4702 SHA512 869a3901d4fc12acb285c94175011ed03dc00b35ab687c67dda458cffab5666cea21bc1b4bf75ef4edeb83b8080452a1c1470248eee54bbd269614a8cab132dc
DIST semantic_version-2.9.0.tar.gz 51123 BLAKE2B c487c49ad17e7ca224ca4b6602abb42d1406dad8d70a3f5d0c536160e5b2d706ff0e1497961e3b9e0391c6d773ab7d0e9699f171f5781cec1d36025450cb7019 SHA512 e08f8e83ad20e94ecd6393d88836e13703fec3c2f89dc7e44fae42d8a929b2460524053fd7440865fa136d22312501a1368b5c3e923997b02383c8227972aa74
diff --git a/dev-python/semantic_version/semantic_version-2.10.0.ebuild b/dev-python/semantic_version/semantic_version-2.10.0.ebuild
new file mode 100644
index 000000000000..e72be53b07fb
--- /dev/null
+++ b/dev-python/semantic_version/semantic_version-2.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="
+ https://github.com/rbarrois/python-semanticversion/
+ https://pypi.org/project/semantic-version/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:django
+}