summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-12 12:27:24 +0100
committerSam James <sam@gentoo.org>2024-11-23 14:00:56 +0000
commit55f7252382771c3b782c11a4f85830337ee351d4 (patch)
tree828cae20607498044b85914829f26034bd04b792
parentdev-libs/liblogging: add 1.0.7 (diff)
downloadgentoo-55f7252382771c3b782c11a4f85830337ee351d4.tar.gz
gentoo-55f7252382771c3b782c11a4f85830337ee351d4.tar.bz2
gentoo-55f7252382771c3b782c11a4f85830337ee351d4.zip
dev-cpp/folly: fix build on arm64
Some Folly tests require lax vector conversions (e.g. 'uint8x8_t' to 'uint64x1_t') to build. Signed-off-by: sin-ack <sin-ack@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-cpp/folly/folly-2024.11.04.00-r1.ebuild (renamed from dev-cpp/folly/folly-2024.11.04.00.ebuild)5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-cpp/folly/folly-2024.11.04.00.ebuild b/dev-cpp/folly/folly-2024.11.04.00-r1.ebuild
index 27be95cd3414..e55339ec78a5 100644
--- a/dev-cpp/folly/folly-2024.11.04.00.ebuild
+++ b/dev-cpp/folly/folly-2024.11.04.00-r1.ebuild
@@ -13,7 +13,7 @@ EAPI=8
# dev-cpp/wangle
# dev-util/watchman
-inherit cmake
+inherit flag-o-matic cmake
DESCRIPTION="An open-source C++ library developed and used at Facebook"
HOMEPAGE="https://github.com/facebook/folly"
@@ -75,6 +75,9 @@ src_configure() {
-DCMAKE_LIBRARY_ARCHITECTURE=$(usex amd64 x86_64 ${ARCH})
)
+ # https://github.com/facebook/folly/issues/1984
+ use arm64 && append-cxxflags "-flax-vector-conversions"
+
cmake_src_configure
}