summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-05-29 17:14:03 +0200
committerHanno <hanno@gentoo.org>2019-05-29 17:14:03 +0200
commit8fef1e209df685b309b625dd8fe1978509d36d3c (patch)
tree1a4f2d9f85fb9fbb46a716fb7e24a9ca2f803c81
parentdev-python/ruamel-yaml: add new version 0.15.96 (diff)
downloadgentoo-8fef1e209df685b309b625dd8fe1978509d36d3c.tar.gz
gentoo-8fef1e209df685b309b625dd8fe1978509d36d3c.tar.bz2
gentoo-8fef1e209df685b309b625dd8fe1978509d36d3c.zip
net-im/gajim: Version bump.
Update dependencies, remove keyring USE flag (no longer optional upstream). Update EAPI to 7, avoid versionator eclass. Add myself as maintainer. Closes: https://bugs.gentoo.org/651616 Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.67, Repoman-2.3.13
-rw-r--r--net-im/gajim/Manifest1
-rw-r--r--net-im/gajim/gajim-1.1.3.ebuild78
-rw-r--r--net-im/gajim/metadata.xml2
3 files changed, 80 insertions, 1 deletions
diff --git a/net-im/gajim/Manifest b/net-im/gajim/Manifest
index 471c77bebd00..0e11c6d16397 100644
--- a/net-im/gajim/Manifest
+++ b/net-im/gajim/Manifest
@@ -1 +1,2 @@
DIST gajim-1.0.3.tar.bz2 5964743 BLAKE2B af4bf2206a962eb68c4df09359fa3a0ccaca1e886d4fad67d9839f5fd4c1fd359c7ee7933d39d8c1ae7dcbde6b72548fef3564a467653064d4d37aa1db234c04 SHA512 a6d7f92a22a9dddc8a4b07eda0aae0b6fb4db57c73133ee19937f7e2a2a82c5351051d1f3627c94a44434276ed001b83d375f708f177962125af66cda8579ec8
+DIST gajim-1.1.3.tar.bz2 8013585 BLAKE2B 7be25380ecfe76ae5e2a7534665688dcca9ff850c12c7a450e8d1f6caab1820a1022750710df0a8a7ae259c5748f55582b272ad83fbdb0560f18e6ab8642bf78 SHA512 18062832f9b9295c7a844c347d5ece4a6db43126d5b58bbf362fdf2f8e082e2241c46dae6d1cbe66ebf2ef19f65618102c3c21fa0079a96fc21511e6e93420ac
diff --git a/net-im/gajim/gajim-1.1.3.ebuild b/net-im/gajim/gajim-1.1.3.ebuild
new file mode 100644
index 000000000000..1548f5c281dd
--- /dev/null
+++ b/net-im/gajim/gajim-1.1.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="sqlite,xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome2-utils distutils-r1 xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://www.gajim.org/"
+SRC_URI="https://www.gajim.org/downloads/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+#KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt geolocation jingle networkmanager remote rst +spell upnp
+ +webp"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo,${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.22:3[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pygobject[cairo,${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ >=dev-python/python-nbxmpp-0.6.9[${PYTHON_USEDEP}]
+ x11-libs/libXScrnSaver
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ >=dev-python/secretstorage-3.1.1[${PYTHON_USEDEP}]
+ >=dev-python/cssutils-1.0.2[${PYTHON_USEDEP}]
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ )
+ networkmanager? ( net-misc/networkmanager[introspection] )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd[introspection] )
+ webp? ( dev-python/pillow[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/net-im/gajim/metadata.xml b/net-im/gajim/metadata.xml
index 67b5f8003508..b7751e37af04 100644
--- a/net-im/gajim/metadata.xml
+++ b/net-im/gajim/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>aidecoe@gentoo.org</email>
+ <email>hanno@gentoo.org</email>
</maintainer>
<longdescription>
A fully featured and easy to use GTK+ Jabber client written in PyGTK.