summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2020-06-14 09:11:17 -0700
committerJoonas Niilola <juippis@gentoo.org>2020-06-16 09:02:51 +0300
commit9c5cfdaff5c2fe59f53fc009a1e83ec212cf5949 (patch)
tree73f956528c74991f4c3391915baff89fd00936f0
parentdev-python/vdirsyncer: 0.16.8 bump (diff)
downloadgentoo-9c5cfdaff5c2fe59f53fc009a1e83ec212cf5949.tar.gz
gentoo-9c5cfdaff5c2fe59f53fc009a1e83ec212cf5949.tar.bz2
gentoo-9c5cfdaff5c2fe59f53fc009a1e83ec212cf5949.zip
dev-python/vdirsyncer: clean old
Signed-off-by: Christopher Head <chead@chead.ca> Closes: https://github.com/gentoo/gentoo/pull/15771 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/vdirsyncer/Manifest1
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
index 5e0a35b54e03..438496531cdd 100644
--- a/dev-python/vdirsyncer/Manifest
+++ b/dev-python/vdirsyncer/Manifest
@@ -1,2 +1 @@
-DIST vdirsyncer-0.16.7.tar.gz 112786 BLAKE2B 19b9ce6e3e9de0a626b9562b4d54b270c1532d93169fe2d872f15c6bf6e1ac94bc623c171e51e871082422116636b4945b58dd172cfca527a010906737f1b6a3 SHA512 218c6781139a9e979077308dc732756cc27ecb67966e4b52be31cb1ebf04d224443036102d5c4bad253b9dcf533939f0b72082166f0fe94e042a7e946b8fad0e
DIST vdirsyncer-0.16.8.tar.gz 115819 BLAKE2B e0140718a1b41875421a7094e02cdeb865c500935e0c97bc18a614551586d79682641726df1a96e17a158604ed309f713f4caf4a484025eca5fbc6acbbe18f97 SHA512 12cb50f592085af37bd9c4207c0d31fdd38fc2a44712eb6288b12e7e7ee9af82070d1d405fa9579e935e545e6c92aafb6f8334ebde4976c4eb9412e78e7c5ada
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild
deleted file mode 100644
index 2a312ce64647..000000000000
--- a/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="Synchronize calendars and contacts"
-HOMEPAGE="https://github.com/pimutils/vdirsyncer"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
- <dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/click-threading-0.2[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
- !=dev-python/requests-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.1[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
-
-python_test() {
- # skip tests needing servers running
- local -x DAV_SERVER=skip
- local -x REMOTESTORAGE_SERVER=skip
- # pytest dies hard if the envvars do not have any value...
- local -x CI=false
- local -x DETERMINISTIC_TESTS=false
- py.test -v || die "Tests fail with ${EPYTHON}"
-}