summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-04-04 22:34:24 -0400
committerMike Gilbert <floppym@gentoo.org>2021-04-05 11:34:46 -0400
commitf82be05190d6b6e6f572de194b1faed95f561aa6 (patch)
tree026dd6b6ee09f0d973aebaf4d9d76a38efe18154
parentmedia-libs/lib3ds: fix .la file removal (diff)
downloadgentoo-f82be05190d6b6e6f572de194b1faed95f561aa6.tar.gz
gentoo-f82be05190d6b6e6f572de194b1faed95f561aa6.tar.bz2
gentoo-f82be05190d6b6e6f572de194b1faed95f561aa6.zip
app-emulation/docker-cli: avoid using ROOT in src_compile
ESYSROOT should be used to locate headers and libraries. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--app-emulation/docker-cli/docker-cli-20.10.2.ebuild4
-rw-r--r--app-emulation/docker-cli/docker-cli-20.10.3.ebuild4
-rw-r--r--app-emulation/docker-cli/docker-cli-20.10.4.ebuild4
-rw-r--r--app-emulation/docker-cli/docker-cli-20.10.5-r1.ebuild4
-rw-r--r--app-emulation/docker-cli/docker-cli-20.10.5.ebuild4
-rw-r--r--app-emulation/docker-cli/metadata.xml6
6 files changed, 13 insertions, 13 deletions
diff --git a/app-emulation/docker-cli/docker-cli-20.10.2.ebuild b/app-emulation/docker-cli/docker-cli-20.10.2.ebuild
index f1767197a60e..21b8e453793b 100644
--- a/app-emulation/docker-cli/docker-cli-20.10.2.ebuild
+++ b/app-emulation/docker-cli/docker-cli-20.10.2.ebuild
@@ -34,8 +34,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}"
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
emake \
LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
VERSION="$(cat VERSION)" \
diff --git a/app-emulation/docker-cli/docker-cli-20.10.3.ebuild b/app-emulation/docker-cli/docker-cli-20.10.3.ebuild
index 2675134a9e69..8d8ca051b48b 100644
--- a/app-emulation/docker-cli/docker-cli-20.10.3.ebuild
+++ b/app-emulation/docker-cli/docker-cli-20.10.3.ebuild
@@ -34,8 +34,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}"
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
emake \
LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
VERSION="$(cat VERSION)" \
diff --git a/app-emulation/docker-cli/docker-cli-20.10.4.ebuild b/app-emulation/docker-cli/docker-cli-20.10.4.ebuild
index b20c515611a7..c65dda796af3 100644
--- a/app-emulation/docker-cli/docker-cli-20.10.4.ebuild
+++ b/app-emulation/docker-cli/docker-cli-20.10.4.ebuild
@@ -33,8 +33,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}"
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
emake \
LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
VERSION="$(cat VERSION)" \
diff --git a/app-emulation/docker-cli/docker-cli-20.10.5-r1.ebuild b/app-emulation/docker-cli/docker-cli-20.10.5-r1.ebuild
index 7869c5f026b7..063f8583dbe6 100644
--- a/app-emulation/docker-cli/docker-cli-20.10.5-r1.ebuild
+++ b/app-emulation/docker-cli/docker-cli-20.10.5-r1.ebuild
@@ -33,8 +33,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}"
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
emake \
LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
VERSION="$(cat VERSION)" \
diff --git a/app-emulation/docker-cli/docker-cli-20.10.5.ebuild b/app-emulation/docker-cli/docker-cli-20.10.5.ebuild
index c23d7586e280..2d0065c9b02c 100644
--- a/app-emulation/docker-cli/docker-cli-20.10.5.ebuild
+++ b/app-emulation/docker-cli/docker-cli-20.10.5.ebuild
@@ -33,8 +33,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}"
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
emake \
LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
VERSION="$(cat VERSION)" \
diff --git a/app-emulation/docker-cli/metadata.xml b/app-emulation/docker-cli/metadata.xml
index 3c49bd23955c..c36c37139fad 100644
--- a/app-emulation/docker-cli/metadata.xml
+++ b/app-emulation/docker-cli/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<maintainer type="person">
<email>williamh@gentoo.org</email>
- <name>William Hubbs</name>
- </maintainer>
- </pkgmetadata>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>