summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-03-06 12:33:04 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-03-06 12:33:42 -0600
commit09ddddc470476ab1a61400a403a2a1fabdc55173 (patch)
tree7e02ab536181d99659496774acd4b1d76cee0d4e /app-admin/kube-bench/kube-bench-0.6.6.ebuild
parentdev-libs/nss: remove prelink files (diff)
downloadgentoo-09ddddc470476ab1a61400a403a2a1fabdc55173.tar.gz
gentoo-09ddddc470476ab1a61400a403a2a1fabdc55173.tar.bz2
gentoo-09ddddc470476ab1a61400a403a2a1fabdc55173.zip
app-admin/kube-bench: 0.6.6 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin/kube-bench/kube-bench-0.6.6.ebuild')
-rw-r--r--app-admin/kube-bench/kube-bench-0.6.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/kube-bench/kube-bench-0.6.6.ebuild b/app-admin/kube-bench/kube-bench-0.6.6.ebuild
new file mode 100644
index 000000000000..82b0b884a1a4
--- /dev/null
+++ b/app-admin/kube-bench/kube-bench-0.6.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Kubernetes Bench for Security runs the CIS Kubernetes Benchmark"
+HOMEPAGE="https://github.com/aquasecurity/kube-bench"
+SRC_URI="https://github.com/aquasecurity/kube-bench/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 MIT MPL-2.0 BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake VERSION=d3cbc64 KUBEBENCH_VERSION=v${PV} build
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/kube-bench
+ doins -r cfg
+}
+
+src_test() {
+ emake tests
+}