summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-10-22 23:31:52 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-10-22 23:32:53 +0200
commitf2d0ba92dc9f05c920045c112e85e06932c83582 (patch)
tree64eb0fcf065481b5b3f74af1ed2eaf0dad336db2 /app-admin/stow
parentapp-admin/stow: Add slot operator in perl dependency, bug 595212 (diff)
downloadgentoo-f2d0ba92dc9f05c920045c112e85e06932c83582.tar.gz
gentoo-f2d0ba92dc9f05c920045c112e85e06932c83582.tar.bz2
gentoo-f2d0ba92dc9f05c920045c112e85e06932c83582.zip
app-admin/stow: Fix perl module installation directory
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-admin/stow')
-rw-r--r--app-admin/stow/stow-2.2.2-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/app-admin/stow/stow-2.2.2-r1.ebuild b/app-admin/stow/stow-2.2.2-r1.ebuild
index 31449528f33c..f0714cc61df9 100644
--- a/app-admin/stow/stow-2.2.2-r1.ebuild
+++ b/app-admin/stow/stow-2.2.2-r1.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit perl-functions
+
DESCRIPTION="GNU Stow is a symlink farm manager"
HOMEPAGE="https://www.gnu.org/software/stow/"
SRC_URI="mirror://gnu/stow/${P}.tar.gz"
@@ -19,3 +21,8 @@ DEPEND="dev-lang/perl
dev-perl/Test-Output
)"
RDEPEND="dev-lang/perl:="
+
+src_configure() {
+ perl_set_version
+ econf "--with-pmdir=${VENDOR_LIB}"
+}