summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-28 07:58:26 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-28 07:58:26 +0100
commit9f7cf7104daab54a7d4ee39953d6b820e40c9cc6 (patch)
tree1ed4c64cc5d9ffe6fa7c9b5aaaaf7ae5e4df89e1 /app-admin
parentdev-python/boto3: Bump to 1.35.90 (diff)
downloadgentoo-9f7cf7104daab54a7d4ee39953d6b820e40c9cc6.tar.gz
gentoo-9f7cf7104daab54a7d4ee39953d6b820e40c9cc6.tar.bz2
gentoo-9f7cf7104daab54a7d4ee39953d6b820e40c9cc6.zip
app-admin/awscli: Bump to 1.36.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.36.31.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 4d637313813b..fe4f82a41cc9 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.36.22.gh.tar.gz 2853997 BLAKE2B a9f309c157595edd37e87834e7b67c16c
DIST aws-cli-1.36.27.gh.tar.gz 2874317 BLAKE2B 5f696b14ba47e6b9b0150e600d7f3241d5bebc1c66e848239221db74dada3c358c5eae795e9d3988383ac431f449729c4226e17724d54d5a6b9531e046c15810 SHA512 0e8dd2bb6dc086f3ff29931c1f41778f6c25e3a173def142f12b6e57fac6edd0df0cd588bc522045561afc44827b8fd2a0bcd582bb72ee01727d22bd0b34a3cc
DIST aws-cli-1.36.28.gh.tar.gz 2874619 BLAKE2B 7a40dc150fd35bd3b1d0eeed6b9a96b1492553aeda58bee92bd68afd07f5dc91aaa0cc8c54b0b5668216ab28020cc8799c0ed1ae414cebc1d2330e508a45cb0e SHA512 f241c72cc067932c0f2f6a2d6eb1ff1172996c8c837ba24cb511ff5c5cac24530b9b1dde3ce385b042cff241cf2dccbb3f7a563d2d7f2f8012d3f5a378f346fb
DIST aws-cli-1.36.29.gh.tar.gz 2875917 BLAKE2B 900a8e3352b8ff3ee68fd6e093d91ad45b74e9408e0e07149f3b7468fbca5fb1bef30a0db9e5382edca22263b8354c0f4e7d01d2e7caa0129328a5b03a6edcdf SHA512 104f72e5b3990a2a17a2f5d961e7a307d0d7c65dc72c30bbdcbcfb1dffb99757b4d4ae2edd5bc7e49cbd6cd3e2298e461f55086dafe103aafbe4b5f2d65235ac
+DIST aws-cli-1.36.31.gh.tar.gz 2876521 BLAKE2B 6ba90d3852b25608bb908b3853bff3de7c0fb94ee6177177abefab16993e7cbd85dec62db8e453c4de2e846bda7ab46efb8e71f6bbb28a458e5bf7cbd53cdc7f SHA512 a0b7de55c3bd518f61d112fa9bd710636ba0118322ceedb959cd2f814fb6dd983516717a3a0c6b3af3a507365da2b73553ede4e0e6dd691601fdbe8e90c0fa68
diff --git a/app-admin/awscli/awscli-1.36.31.ebuild b/app-admin/awscli/awscli-1.36.31.ebuild
new file mode 100644
index 000000000000..2960403cf7e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.31.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}