summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-12-30 16:00:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-12-31 09:56:31 +0100
commita15c4993d574fc90cf27767125ebb0da2c1f4f11 (patch)
treea3360b2a6f0c076e583ea0aa850845340f4b753d /app-admin
parentdev-ruby/rdtool: enable ruby34 (diff)
downloadgentoo-a15c4993d574fc90cf27767125ebb0da2c1f4f11.tar.gz
gentoo-a15c4993d574fc90cf27767125ebb0da2c1f4f11.tar.bz2
gentoo-a15c4993d574fc90cf27767125ebb0da2c1f4f11.zip
app-admin/qtpass: Port to Qt6
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-buildfix.patch23
-rw-r--r--app-admin/qtpass/qtpass-1.4.0-r1.ebuild66
2 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-buildfix.patch b/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-buildfix.patch
new file mode 100644
index 000000000000..c996cb9bf8e7
--- /dev/null
+++ b/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-buildfix.patch
@@ -0,0 +1,23 @@
+From c3d04090260edd77e56c0602f264d923b236c42f Mon Sep 17 00:00:00 2001
+From: Arthur Bols <arthur@bols.dev>
+Date: Tue, 5 Nov 2024 17:20:56 +0100
+Subject: [PATCH] fix: add missing QDirIterator include
+
+Added missing include for QDirIterator in mainwindow.cpp to resolve compilation
+errors introduced with Qt 6.8.
+---
+ src/mainwindow.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/mainwindow.cpp b/src/mainwindow.cpp
+index 66b87dc2..691b8593 100644
+--- a/src/mainwindow.cpp
++++ b/src/mainwindow.cpp
+@@ -19,6 +19,7 @@
+ #include <QCloseEvent>
+ #include <QDesktopServices>
+ #include <QDialog>
++#include <QDirIterator>
+ #include <QFileInfo>
+ #include <QInputDialog>
+ #include <QLabel>
diff --git a/app-admin/qtpass/qtpass-1.4.0-r1.ebuild b/app-admin/qtpass/qtpass-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..e6a4bd5f91d9
--- /dev/null
+++ b/app-admin/qtpass/qtpass-1.4.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop qmake-utils
+
+DESCRIPTION="Multi-platform GUI for pass, the standard unix password manager"
+HOMEPAGE="https://qtpass.org https://github.com/IJHack/qtpass"
+SRC_URI="https://github.com/IJHack/qtpass/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/QtPass-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ app-admin/pass
+ app-admin/gopass
+ )
+ dev-qt/qtbase:6[gui,network,widgets]
+ net-misc/x11-ssh-askpass
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtsvg:6
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+DOCS=( {CHANGELOG,CONTRIBUTING,FAQ,README}.md )
+
+PATCHES=( "${FILESDIR}"/${P}-qt-6.8-buildfix.patch )
+
+src_prepare() {
+ default
+
+ if ! use test ; then
+ sed -i '/SUBDIRS += src /s/tests //' \
+ qtpass.pro || die "sed for qtpass.pro failed"
+ fi
+}
+
+src_configure() {
+ eqmake6 PREFIX="${EPREFIX}"/usr
+}
+
+src_test() {
+ local -x QT_QPA_PLATFORM=offscreen
+ default
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ insinto /usr/share/qtpass/translations
+ doins src/.qm/*.qm
+
+ doman qtpass.1
+ domenu qtpass.desktop
+ newicon artwork/icon.png qtpass-icon.png
+ insinto /usr/share/metainfo
+ doins qtpass.appdata.xml
+}