summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/rar/rar-4.2.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/rar/rar-4.2.0.ebuild')
-rw-r--r--app-arch/rar/rar-4.2.0.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/app-arch/rar/rar-4.2.0.ebuild b/app-arch/rar/rar-4.2.0.ebuild
new file mode 100644
index 000000000000..88aaa0266534
--- /dev/null
+++ b/app-arch/rar/rar-4.2.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=4
+
+DESCRIPTION="RAR compressor/uncompressor"
+HOMEPAGE="http://www.rarsoft.com/"
+URI_x86="http://www.rarlab.com/rar/rarlinux-${PV}.tar.gz"
+URI_amd64="http://www.rarlab.com/rar/rarlinux-x64-${PV}.tar.gz"
+URI_w64="http://www.rarlab.com/rar/winrar-x64-${PV//.}.exe"
+SRC_URI="x86? ( ${URI_x86} )
+ amd64? ( ${URI_amd64} )
+ all_sfx? (
+ ${URI_x86}
+ ${URI_amd64}
+ ${URI_w64}
+ )"
+
+LICENSE="RAR"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="all_sfx static"
+
+DEPEND="all_sfx? ( app-arch/unrar )"
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}/${PN}
+
+QA_FLAGS_IGNORED="opt/rar/default.sfx
+ opt/rar/default-elf32.sfx
+ opt/rar/default-elf64.sfx
+ opt/rar/default-win32.sfx
+ opt/rar/default-win64.sfx
+ opt/rar/WinCon.SFX
+ opt/rar/WinCon64.SFX
+ opt/rar/Zip.SFX
+ opt/rar/Zip64.SFX
+ opt/rar/unrar
+ opt/rar/rar"
+QA_PRESTRIPPED=${QA_FLAGS_IGNORED}
+
+src_unpack() {
+ use x86 && unpack ${URI_x86##*/}
+ use amd64 && unpack ${URI_amd64##*/}
+ rm -f "${S}"/license.txt
+ if use all_sfx ; then
+ mkdir sfx
+ cd sfx
+ unpack ${URI_x86##*/}
+ mv rar/default.sfx default-elf32.sfx || die
+ unpack ${URI_amd64##*/}
+ mv rar/default.sfx default-elf64.sfx || die
+ ln -s "${DISTDIR}"/${URI_w64##*/} w64.rar
+ unpack ./w64.rar
+ mv Default.SFX default-win32.sfx || die
+ mv Default64.SFX default-win64.sfx || die
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ exeinto /opt/rar
+ doexe rar unrar || die
+ use static && { newexe rar_static rar || die ; }
+
+ dodir /opt/bin
+ dosym ../rar/rar /opt/bin/rar || die
+ dosym ../rar/unrar /opt/bin/unrar || die
+
+ insinto /opt/rar
+ if use all_sfx ; then
+ doins "${WORKDIR}"/sfx/*.{sfx,SFX} || die
+ else
+ doins default.sfx || die
+ fi
+ doins rarfiles.lst || die
+ dodoc *.txt
+}