summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-05-08 22:56:03 +0200
committerSam James <sam@gentoo.org>2023-05-11 21:03:25 +0100
commit43fe2e5cd3a2f232e2305505a116e1a1dc0da645 (patch)
tree971c07ec2e33fa37393b95d69b3fb73cb61ff6c1 /app-backup/rsnapshot/rsnapshot-1.4.4-r1.ebuild
parentapp-backup/hdup: switch to virtual/openssh (diff)
downloadgentoo-43fe2e5cd3a2f232e2305505a116e1a1dc0da645.tar.gz
gentoo-43fe2e5cd3a2f232e2305505a116e1a1dc0da645.tar.bz2
gentoo-43fe2e5cd3a2f232e2305505a116e1a1dc0da645.zip
app-backup/rsnapshot: switch to virtual/openssh
Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup/rsnapshot/rsnapshot-1.4.4-r1.ebuild')
-rw-r--r--app-backup/rsnapshot/rsnapshot-1.4.4-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-backup/rsnapshot/rsnapshot-1.4.4-r1.ebuild b/app-backup/rsnapshot/rsnapshot-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..7d9892a4c31b
--- /dev/null
+++ b/app-backup/rsnapshot/rsnapshot-1.4.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A filesystem backup utility based on rsync"
+HOMEPAGE="https://www.rsnapshot.org"
+SRC_URI="https://www.rsnapshot.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
+
+RDEPEND="
+ >=dev-lang/perl-5.8.2
+ dev-perl/Lchown
+ >=sys-apps/util-linux-2.12-r4
+ >=sys-apps/coreutils-5.0.91-r4
+ virtual/openssh
+ >=net-misc/rsync-2.6.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # remove '/etc/' since we don't place it here, bug #461554
+ sed -i -e 's:/etc/rsnapshot.conf.default:rsnapshot.conf.default:' rsnapshot-program.pl || die
+}
+
+src_install() {
+ docompress -x "/usr/share/doc/${PF}/rsnapshot.conf.default"
+
+ # Change sysconfdir to install the template file as documentation
+ # rather than in /etc.
+ emake install DESTDIR="${D}" \
+ sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
+
+ dodoc README.md AUTHORS ChangeLog \
+ docs/Upgrading_from_1.1
+
+ docinto utils
+ dodoc utils/{README,rsnaptar,*.sh,*.pl}
+
+ docinto utils/rsnapshotdb
+ dodoc utils/rsnapshotdb/*
+}
+
+pkg_postinst() {
+ elog "The template configuration file has been installed as"
+ elog " /usr/share/doc/${PF}/rsnapshot.conf.default"
+ elog "Copy and edit the the above file as /etc/rsnapshot.conf"
+}