summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 14:10:05 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 16:06:13 +0100
commitdb695fb165071cb86660dda3f99bc1930d54150d (patch)
tree0b1e4c488b6373a9145d08aa60d87328686599f7 /app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
parentI forgot to copy&paste dev-libs/libzeitgeist there after handling its reverse... (diff)
downloadgentoo-db695fb165071cb86660dda3f99bc1930d54150d.tar.gz
gentoo-db695fb165071cb86660dda3f99bc1930d54150d.tar.bz2
gentoo-db695fb165071cb86660dda3f99bc1930d54150d.zip
app-benchmarks/pipebench: [QA] Respect LDFLAGS
Closes: https://bugs.gentoo.org/334909 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-benchmarks/pipebench/pipebench-0.40-r2.ebuild')
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r2.ebuild23
1 files changed, 5 insertions, 18 deletions
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
index 610bcc5df90d..2542f0f9d36e 100644
--- a/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
+++ b/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Measures the speed of stdin/stdout communication"
HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
@@ -14,22 +14,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~arm-linux ~x86-linux"
IUSE=""
-src_prepare() {
- sed -i Makefile \
- -e 's:CFLAGS=-Wall:CFLAGS+= -Wall:' \
- -e 's:$(CFLAGS) -o:$(LDFLAGS) &:g' \
- -e "s:/usr/local/bin/:${ED}/usr/bin:" \
- -e "s:/usr/local/man/man1/:${ED}/usr/share/man/man1:" \
- || die "sed Makefile"
- default
-}
-
-src_compile() {
- emake CC=$(tc-getCC)
-}
+PATCHES=( "${FILESDIR}"/${PN}-0.40-fix-build-system.patch )
-src_install() {
- dodir /usr/{bin,share/man/man1}
- emake install
- dodoc README
+src_configure() {
+ append-cflags -Wall -w -pedantic
+ tc-export CC
}