summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-13 19:30:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-13 21:23:13 +0200
commit91ef4e9c902e40212a0b32cd964125f930c20b78 (patch)
treedafb23e13201883ee987361e47a847ada1128202 /app-containers
parentdev-lang/boogie: bump to 3.3.2 (diff)
downloadgentoo-91ef4e9c902e40212a0b32cd964125f930c20b78.tar.gz
gentoo-91ef4e9c902e40212a0b32cd964125f930c20b78.tar.bz2
gentoo-91ef4e9c902e40212a0b32cd964125f930c20b78.zip
app-containers/distrobox: bump to 1.8.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/distrobox/Manifest1
-rw-r--r--app-containers/distrobox/distrobox-1.8.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index edfce52369f2..39d70f8a212b 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1 +1,2 @@
DIST distrobox-1.7.2.1.tar.gz 6888919 BLAKE2B 1fd4e49585f686cf9f434c3285935bdda1131684b74dfcc20b018ab9853fb13516f3dbaf7c16b9ea55a0d038e3d9eb297bcea74c95755fbe60ef6512a9ce0df8 SHA512 aaf4324a9a31844dc08a6cc4e06d3b725675c92df01b558e733c96701d7e9700baabc1afad97ce5e2a8e2345defcea71c85f0ea6667249316f850aeca5aea149
+DIST distrobox-1.8.0.tar.gz 6915152 BLAKE2B ac1d3e8b99c1f9ec93518ec92c023aab76849a258e0482c23667ac3e7f4f80b4e93a4c7f0636c1bdd93dfe3dc67ccfc28261fb7f83d998259b8a0209534d3c90 SHA512 5d34c8aea935a6ea328071268b63ba8a5cd3e7962f85e9753e0adfcca6121c560d790124a1ce288ec6362e4c58e4e732d45a2873053a48a3d9b8bd823ddd72c5
diff --git a/app-containers/distrobox/distrobox-1.8.0.ebuild b/app-containers/distrobox/distrobox-1.8.0.ebuild
new file mode 100644
index 000000000000..0a328c47011d
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.it/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}