summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-20 22:10:29 +0100
committerMarek Szuba <marecki@gentoo.org>2022-01-20 22:10:29 +0100
commit4b8610761ef3da96cacfe7fb2874f9d8af9ea68d (patch)
tree046eacecff801148253d46075fcee175de19b191 /app-crypt
parentapp-forensics/lynis: Version bump, remove old (diff)
downloadgentoo-4b8610761ef3da96cacfe7fb2874f9d8af9ea68d.tar.gz
gentoo-4b8610761ef3da96cacfe7fb2874f9d8af9ea68d.tar.bz2
gentoo-4b8610761ef3da96cacfe7fb2874f9d8af9ea68d.zip
app-crypt/yubioath-desktop: do not import legacy QtQuick module
yubioath-desktop looks for Qt Quick Controls 2 at configure time yet one of the QML scripts attempts to import QtQuick.Dialogs - which belongs to deprecated Qt Quick Controls 1. Patch the offending import out so that said QML script uses the class Dialog from QtQuick.Controls instead; fortunately the two classes are largely API-compatible and the script does not seem to trigger any of the (few according to documentation) incompatibilities which do exist. Closes: https://bugs.gentoo.org/831506 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubioath-desktop/files/yubioath-desktop-5.1.0-qtquickcontrols1.patch10
-rw-r--r--app-crypt/yubioath-desktop/yubioath-desktop-5.1.0-r2.ebuild (renamed from app-crypt/yubioath-desktop/yubioath-desktop-5.1.0-r1.ebuild)7
2 files changed, 15 insertions, 2 deletions
diff --git a/app-crypt/yubioath-desktop/files/yubioath-desktop-5.1.0-qtquickcontrols1.patch b/app-crypt/yubioath-desktop/files/yubioath-desktop-5.1.0-qtquickcontrols1.patch
new file mode 100644
index 000000000000..f5d80643bf84
--- /dev/null
+++ b/app-crypt/yubioath-desktop/files/yubioath-desktop-5.1.0-qtquickcontrols1.patch
@@ -0,0 +1,10 @@
+--- a/qml/NewCredentialView.qml
++++ b/qml/NewCredentialView.qml
+@@ -3,7 +3,6 @@
+ import QtQuick.Layouts 1.3
+ import QtQuick.Controls.Material 2.2
+ import QtGraphicalEffects 1.0
+-import QtQuick.Dialogs 1.2
+ import Qt.labs.platform 1.0
+ import QtQuick.Window 2.2
+
diff --git a/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0-r1.ebuild b/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0-r2.ebuild
index c2f7b927166a..4c36fdb3a992 100644
--- a/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0-r1.ebuild
+++ b/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,7 +34,10 @@ RDEPEND="${DEPEND}
$(python_gen_cond_dep '>=app-crypt/yubikey-manager-4.0.0[${PYTHON_USEDEP}]')
dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]"
-PATCHES=( "${FILESDIR}"/${P}-bin-installdir.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-bin-installdir.patch
+ "${FILESDIR}"/${P}-qtquickcontrols1.patch
+)
src_prepare() {
default