summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-01-15 02:35:23 -0600
committerMatthias Maier <tamiko@gentoo.org>2020-01-15 02:50:43 -0600
commit98bda6b93d184903bd7c91f05f7a1da7b94c5e86 (patch)
tree399e52ba84b5d4702ff5348211eef2926a497ffa /app-crypt
parentsci-mathematics/why3-for-spark: Needs a newer coq version (diff)
downloadgentoo-98bda6b93d184903bd7c91f05f7a1da7b94c5e86.tar.gz
gentoo-98bda6b93d184903bd7c91f05f7a1da7b94c5e86.tar.bz2
gentoo-98bda6b93d184903bd7c91f05f7a1da7b94c5e86.zip
app-crypt/jitterentropy-rngd: new package
Add the jitterentropy-rng userland daemon. This package requires the jitterentropy-rng.ko kernel module to be loaded. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/jitterentropy-rngd/Manifest1
-rw-r--r--app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch16
-rw-r--r--app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild24
-rw-r--r--app-crypt/jitterentropy-rngd/metadata.xml17
4 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy-rngd/Manifest b/app-crypt/jitterentropy-rngd/Manifest
new file mode 100644
index 000000000000..25bae508a6c3
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/Manifest
@@ -0,0 +1 @@
+DIST jitterentropy-rngd-1.1.0.tar.gz 25891 BLAKE2B f711b173c68b74cbc0dbac1ae1b7a2beb5352b38e411f96172aa36ac7f720f05469f5fac2fa97b3514ec11fbe2ccfe0351ee7df8f51a8b36a566635ef93e4d08 SHA512 32835475b604e502caaab9b0d1cd9fe2920c126a27841669f6cf9c717094bfd4c11feab0f9f706ee4cf4caeedf26ced7039075499a3faaf41830c72968544646
diff --git a/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch b/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch
new file mode 100644
index 000000000000..069c005df3a6
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch
@@ -0,0 +1,16 @@
+diff --git a/Makefile b/Makefile
+index 55b65b1..b04f270 100644
+--- a/Makefile
++++ b/Makefile
+@@ -36,10 +36,9 @@ $(NAME): $(OBJS)
+ strip: $(NAME)
+ $(STRIP) --strip-unneeded $(NAME)
+
+-install: strip
++install:
+ $(INSTALL) -D -m 0755 $(NAME) $(DESTDIR)$(PREFIX)/sbin/$(NAME)
+ $(INSTALL) -D -m 0644 $(NAME).1 $(DESTDIR)$(PREFIX)/share/man/man1/$(NAME).1
+- gzip -9 $(DESTDIR)$(PREFIX)/share/man/man1/$(NAME).1
+ sed "s|@PATH@|$(PREFIX)/sbin|" jitterentropy.service.in > jitterentropy.service
+ $(INSTALL) -D -m 0644 jitterentropy.service $(DESTDIR)$(UNITDIR)/jitterentropy.service
+
diff --git a/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
new file mode 100644
index 000000000000..bd3a671e48d4
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Jitter RNG daemon"
+HOMEPAGE="http://www.chronox.de/jent.html"
+SRC_URI="https://github.com/smuellerDD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-do-not-strip-and-compress.patch
+)
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+ UNITDIR="$(systemd_get_systemunitdir)" install
+}
diff --git a/app-crypt/jitterentropy-rngd/metadata.xml b/app-crypt/jitterentropy-rngd/metadata.xml
new file mode 100644
index 000000000000..5db19de18fb4
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+</maintainer>
+<longdescription>
+ The Jitter RNG daemon provides an entropy source that feeds into the
+ Linux /dev/random device if its entropy runs low. It updates the
+ /dev/random entropy estimator such that the newly provided entropy
+ unblocks /dev/random.
+</longdescription>
+<upstream>
+ <remote-id type="github">smuellerDD/jitterentropy-rngd</remote-id>
+</upstream>
+</pkgmetadata>