summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-26 02:49:00 +0000
committerSam James <sam@gentoo.org>2024-11-26 02:55:23 +0000
commitf49a9884a55e351b80549af8062414a9b2080a84 (patch)
tree9d1d1c5f2b772cd1de9f41c16a27a5e23e15bae1 /app-crypt
parentdev-scheme/guile: fix C23 compat for 3.0.10 (diff)
downloadgentoo-f49a9884a55e351b80549af8062414a9b2080a84.tar.gz
gentoo-f49a9884a55e351b80549af8062414a9b2080a84.tar.bz2
gentoo-f49a9884a55e351b80549af8062414a9b2080a84.zip
app-crypt/mhash: build w/ -std=gnu17
We already have tonnes of patches for proper C99 compat. Closes: https://bugs.gentoo.org/943960 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mhash/mhash-0.9.9.9-r3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild b/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
index ed01e8b388cf..0d5b3371eb8e 100644
--- a/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
+++ b/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Library providing a uniform interface to a large number of hash algorithms"
HOMEPAGE="https://mhash.sourceforge.net/"
@@ -52,6 +52,9 @@ src_prepare() {
}
src_configure() {
+ # bug #943960
+ append-cflags -std=gnu17
+
econf $(use_enable static-libs static)
}