summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-12 17:04:58 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-12 17:59:23 -0400
commitac2b117e17fc4a6cbeaf1a4123fd9bf94e9ed606 (patch)
tree4dc3eaa4c41dd9bc0af7b18f1908e35dc77296a3 /app-dicts/gnome-dictionary
parentapp-crypt/seahorse: Version bump to 40.0 (diff)
downloadgentoo-ac2b117e17fc4a6cbeaf1a4123fd9bf94e9ed606.tar.gz
gentoo-ac2b117e17fc4a6cbeaf1a4123fd9bf94e9ed606.tar.bz2
gentoo-ac2b117e17fc4a6cbeaf1a4123fd9bf94e9ed606.zip
app-dicts/gnome-dictionary: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-dicts/gnome-dictionary')
-rw-r--r--app-dicts/gnome-dictionary/Manifest1
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-40.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
index fedd9a820537..0d3c3d8f0a73 100644
--- a/app-dicts/gnome-dictionary/Manifest
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -1 +1,2 @@
DIST gnome-dictionary-3.26.1.tar.xz 662048 BLAKE2B 3b77d3632629f8502476f029ab9ba3c66225cd619992e185b1403adfeba718b7e0fa0f32762eb086c1e9ef80a08cf79cd872e2ca3026b8cb3975954077c5f7c1 SHA512 da7169795740295c13f02143f5263603f0f6c621e96cecf88a4ee089114399d59f083987bc4571821467da64dc43f00bebbe4ea66b46a035088f85d35d6aee27
+DIST gnome-dictionary-40.0.tar.xz 603388 BLAKE2B 1fae73ea5b554786f1ee1bf641b0dc94ee8953a045e4a59b72823075b8c0905d0098827ad35f94e26d26fcbdbed1fd2980391ce582871ae6df4d273d9de5add4 SHA512 96e8c5efbba43e1a7d247703ac17cbcb8579cc633f6db74b6fe4431e0b1aed47ab76fd15cc114497b5ee76fb33b57fd9936cc869ffe905f208c836b5a231b126
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-40.0.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-40.0.ebuild
new file mode 100644
index 000000000000..665d4408cceb
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-40.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0" # does not provide a public libgdict-1.0.so anymore
+IUSE="ipv6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.21.2:3
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use ipv6 use_ipv6)
+ -Dbuild_man=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}