summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-16 19:56:59 +0000
committerSam James <sam@gentoo.org>2022-07-16 19:56:59 +0000
commit9e2c1b2c21827fefc11cde8e31a6a3c65bd105af (patch)
tree5764094c6f193930637ba57f0ec551e498ca2e33 /app-doc/eclass-manpages/eclass-manpages-20220716.ebuild
parentapp-doc/eclass-manpages: add 20220716 (diff)
downloadgentoo-9e2c1b2c21827fefc11cde8e31a6a3c65bd105af.tar.gz
gentoo-9e2c1b2c21827fefc11cde8e31a6a3c65bd105af.tar.bz2
gentoo-9e2c1b2c21827fefc11cde8e31a6a3c65bd105af.zip
app-doc/eclass-manpages: use live template
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc/eclass-manpages/eclass-manpages-20220716.ebuild')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-20220716.ebuild42
1 files changed, 36 insertions, 6 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-20220716.ebuild b/app-doc/eclass-manpages/eclass-manpages-20220716.ebuild
index 3f301df02e67..4bbfc72582a4 100644
--- a/app-doc/eclass-manpages/eclass-manpages-20220716.ebuild
+++ b/app-doc/eclass-manpages/eclass-manpages-20220716.ebuild
@@ -3,19 +3,49 @@
EAPI=8
+# Instructions to make a dist tarball:
+# git clone https://github.com/mgorny/eclass-to-manpage && cd eclass-to-manpage
+# make dist ECLASSDIR=~/g/eclass/
+
DESCRIPTION="Collection of Gentoo eclass manpages"
HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
-SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
+ https://github.com/gentoo/gentoo.git"
+ inherit git-r3
+
+ MY_ECLASSDIR="eclass"
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+ # Keep the keywords stable. No need to change to ~arch.
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+ MY_ECLASSDIR="."
+fi
LICENSE="GPL-2"
SLOT="0"
-# Keep the keywords stable. No need to change to ~arch.
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-BDEPEND="app-arch/xz-utils
- sys-apps/gawk
+BDEPEND="sys-apps/gawk
sys-apps/groff"
+src_unpack() {
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_fetch
+ git-r3_fetch "https://github.com/mgorny/eclass-to-manpage"
+
+ git-r3_checkout '' '' '' eclass
+ git-r3_checkout "https://github.com/mgorny/eclass-to-manpage"
+ else
+ default
+ fi
+}
+
+src_compile() {
+ emake ECLASSDIR=${MY_ECLASSDIR}
+}
+
src_install() {
- emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+ emake install ECLASSDIR=${MY_ECLASSDIR} DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
}