summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-28 03:00:59 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-28 03:08:16 -0600
commit4dcf9f8457256d2e87b6c9ee5a18b65a0bc3c8c8 (patch)
tree848f30a43a2745e41c9c027a41450e342c72d34e /app-editors/vim/vim-9999.ebuild
parentapp-editors/vim-core: version bump to 8.1.0648 (diff)
downloadgentoo-4dcf9f8457256d2e87b6c9ee5a18b65a0bc3c8c8.tar.gz
gentoo-4dcf9f8457256d2e87b6c9ee5a18b65a0bc3c8c8.tar.bz2
gentoo-4dcf9f8457256d2e87b6c9ee5a18b65a0bc3c8c8.zip
app-editors/vim: version bump to 8.1.0648
Closes: https://bugs.gentoo.org/666680 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-editors/vim/vim-9999.ebuild')
-rw-r--r--app-editors/vim/vim-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 0b199842bec1..abe19b7c71ab 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=6
VIM_VERSION="8.1"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
PYTHON_REQ_USE="threads(+)"
USE_RUBY="ruby23 ruby24 ruby25"
-inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop
+inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils gnome2-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -302,6 +302,10 @@ pkg_postinst() {
# Call eselect vi update
eselect_vi_update
+
+ # update desktop file mime/icon caches
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
}
pkg_postrm() {
@@ -310,4 +314,8 @@ pkg_postrm() {
# Call eselect vi update
eselect_vi_update
+
+ # update desktop file mime/icon caches
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
}