summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-07-09 08:05:50 +0200
committerSam James <sam@gentoo.org>2023-07-26 04:11:46 +0100
commit41bab2942dd26d8d17ca509237fac9e9b0962dc9 (patch)
tree6bd00a64dc86f89dec53e4f6a5f366e516a4e416 /app-editors/vis
parentapp-admin/sudo: add 1.9.14_p3 (diff)
downloadgentoo-41bab2942dd26d8d17ca509237fac9e9b0962dc9.tar.gz
gentoo-41bab2942dd26d8d17ca509237fac9e9b0962dc9.tar.bz2
gentoo-41bab2942dd26d8d17ca509237fac9e9b0962dc9.zip
app-editors/vis: drop 0.7, 0.7-r1
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/31807 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/vis')
-rw-r--r--app-editors/vis/Manifest1
-rw-r--r--app-editors/vis/vis-0.7-r1.ebuild92
-rw-r--r--app-editors/vis/vis-0.7.ebuild77
3 files changed, 0 insertions, 170 deletions
diff --git a/app-editors/vis/Manifest b/app-editors/vis/Manifest
index d0c8ab5655e7..1d57d4db3820 100644
--- a/app-editors/vis/Manifest
+++ b/app-editors/vis/Manifest
@@ -1,3 +1,2 @@
-DIST vis-0.7.tar.gz 403918 BLAKE2B 5e4930fdb14ed42a2daf6682a99107ee6eb59e99e348abab5262bdbc53956dd9ccd094695d7f53c6770d10e46b2812b0e07ff90184ff920790f5b95f4091a610 SHA512 ccc6a054fea6917e7751882468a74c30c712f7ec400a913c95c0084691f706e2bee54efb86b75be8b121c9a209c7e587e72e5474c55271d9943e91fc8aaf9bac
DIST vis-0.8.tar.gz 404496 BLAKE2B eafb7098a6c8e0d8f277be66984d5fd298ac86d524a4219a7d7730599157ca68c040615622cd1680b101e1cd003eba03343496762d0d4dc2766a079116f21eea SHA512 ab4eda075034955411bdbc0ade2fe9149a48c644fa2f70add8d3b9d749f86b98a4e429745b5cae7fdbc0a1e07c8587539a055cd1c6734bb59e43c580c949e0aa
DIST vis-test-0.5.tar.gz 99314 BLAKE2B 988d7e93d0f3c58d2fc8fbe9293049c6a3cc44dfcbfbd4f42f7992815cf33a604340b59171dcd880f7180ae56e3f73f46684b7aacd96438480db6c4592851f2c SHA512 c41b40f23a45a7ebd9c16aa853d9c3b517767cb88ff8dc268da44276a02aa8c77de0fc6aa243a1e4cdfbc27182870b82d0b9bc892bb87ea74d5275d76c554ed1
diff --git a/app-editors/vis/vis-0.7-r1.ebuild b/app-editors/vis/vis-0.7-r1.ebuild
deleted file mode 100644
index 8f1fe78c20dd..000000000000
--- a/app-editors/vis/vis-0.7-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PTV=0.5
-LUA_COMPAT=( lua5-2 lua5-3 lua5-4 )
-
-inherit lua-single optfeature
-
-if [ "${PV}" == "9999" ]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/martanne/vis.git"
-else
- SRC_URI="https://github.com/martanne/vis/releases/download/v${PV}/${P}.tar.gz
- test? ( https://github.com/martanne/vis-test/releases/download/v${MY_PTV}/vis-test-${MY_PTV}.tar.gz )"
- KEYWORDS="~amd64 ~arm ~riscv ~x86"
-fi
-
-DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
-HOMEPAGE="https://github.com/martanne/vis"
-LICENSE="ISC MIT"
-SLOT="0"
-IUSE="+ncurses +lua selinux test tre"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-# - Known to also work with NetBSD curses
-DEPEND="dev-libs/libtermkey
- sys-apps/acl
- ncurses? ( sys-libs/ncurses:0= )
- lua? ( ${LUA_DEPS} )
- tre? ( dev-libs/tre )"
-RDEPEND="${DEPEND}
- app-eselect/eselect-vi"
-# lpeg: https://github.com/martanne/vis-test/issues/28
-BDEPEND="test? (
- $(lua_gen_cond_dep 'dev-lua/lpeg[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
-)"
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- if use test; then
- if [ ! "${PV}" == "9999" ]; then
- rm -r test || die
- mv "${WORKDIR}/vis-test-${MY_PTV}" test || die
- fi
-
- # https://bugs.gentoo.org/722014 https://github.com/martanne/vis-test/pull/22
- sed -i 's;./ccan-config > config.h;./ccan-config "${CC}" ${CFLAGS} > config.h;' test/core/Makefile || die
-
- # https://github.com/martanne/vis-test/pull/29
- sed -i 's;cpp -P;${CPP:-cpp} -P;' test/vim/test.sh || die
-
- # https://github.com/martanne/vis-test/issues/27 a Werror clone
- sed -i 's;|| strstr(output, "warning");;' test/core/ccan-config.c || die
- fi
-
- sed -i 's|STRIP?=.*|STRIP=true|' Makefile || die
- sed -i 's|${DOCPREFIX}/vis|${DOCPREFIX}|' Makefile || die
- sed -i 's|DOCUMENTATION = LICENSE|DOCUMENTATION =|' Makefile || die
-
- default
-}
-
-src_configure() {
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable lua) \
- $(use_enable ncurses curses) \
- $(use_enable selinux) \
- $(use_enable tre) || die
-}
-
-update_symlinks() {
- einfo "Calling eselect vi update --if-unset"
- eselect vi update --if-unset
-}
-
-pkg_postrm() {
- update_symlinks
-}
-
-pkg_postinst() {
- update_symlinks
- optfeature "syntax highlighting support" dev-lua/lpeg
-}
diff --git a/app-editors/vis/vis-0.7.ebuild b/app-editors/vis/vis-0.7.ebuild
deleted file mode 100644
index 0638ef99f5fc..000000000000
--- a/app-editors/vis/vis-0.7.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PTV=0.5
-LUA_COMPAT=( lua5-2 lua5-3 )
-
-inherit lua-single optfeature
-
-DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
-HOMEPAGE="https://github.com/martanne/vis"
-SRC_URI="https://github.com/martanne/vis/releases/download/v${PV}/${P}.tar.gz
- test? ( https://github.com/martanne/vis-test/releases/download/v${MY_PTV}/vis-test-${MY_PTV}.tar.gz )"
-LICENSE="ISC MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~riscv x86"
-IUSE="+ncurses +lua selinux test tre"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-# - Known to also work with NetBSD curses
-DEPEND="dev-libs/libtermkey
- ncurses? ( sys-libs/ncurses:0= )
- lua? ( ${LUA_DEPS} )
- tre? ( dev-libs/tre:= )"
-RDEPEND="${DEPEND}
- app-eselect/eselect-vi"
-# https://github.com/martanne/vis-test/issues/28
-BDEPEND="test? ( $(lua_gen_cond_dep 'dev-lua/lpeg[${LUA_USEDEP}]') )"
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- if use test; then
- rm -r test || die
- mv "${WORKDIR}/vis-test-${MY_PTV}" test || die
-
- # https://bugs.gentoo.org/722014 https://github.com/martanne/vis-test/pull/22
- sed -i 's;./ccan-config > config.h;./ccan-config "${CC}" ${CFLAGS} > config.h;' test/core/Makefile || die
-
- # https://github.com/martanne/vis-test/issues/27 a Werror clone
- sed -i 's;|| strstr(output, "warning");;' test/core/ccan-config.c || die
- fi
-
- sed -i 's|STRIP?=.*|STRIP=true|' Makefile || die
- sed -i 's|${DOCPREFIX}/vis|${DOCPREFIX}|' Makefile || die
- sed -i 's|DOCUMENTATION = LICENSE|DOCUMENTATION =|' Makefile || die
-
- default
-}
-
-src_configure() {
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable lua) \
- $(use_enable ncurses curses) \
- $(use_enable selinux) \
- $(use_enable tre) || die
-}
-
-update_symlinks() {
- einfo "Calling eselect vi update --if-unset"
- eselect vi update --if-unset
-}
-
-pkg_postrm() {
- update_symlinks
-}
-
-pkg_postinst() {
- update_symlinks
- optfeature "syntax highlighting support" dev-lua/lpeg
-}