summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-10 01:59:37 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-10 02:04:36 +0100
commitcb18383f72e361b80c3a7e9baf529c570037bbad (patch)
tree9f15a6e246d6862e653935c3bb1260ccfd150bb5 /app-emacs/julia-repl
parentapp-emacs/julia-mode: new package; add 0.4_p20211023 (diff)
downloadgentoo-cb18383f72e361b80c3a7e9baf529c570037bbad.tar.gz
gentoo-cb18383f72e361b80c3a7e9baf529c570037bbad.tar.bz2
gentoo-cb18383f72e361b80c3a7e9baf529c570037bbad.zip
app-emacs/julia-repl: new package; add 1.3.0_p20220225
2022.02.25 snapshot Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/julia-repl')
-rw-r--r--app-emacs/julia-repl/Manifest1
-rw-r--r--app-emacs/julia-repl/files/50julia-repl-gentoo.el4
-rw-r--r--app-emacs/julia-repl/files/julia-repl-force-compile.patch9
-rw-r--r--app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild46
-rw-r--r--app-emacs/julia-repl/metadata.xml23
5 files changed, 83 insertions, 0 deletions
diff --git a/app-emacs/julia-repl/Manifest b/app-emacs/julia-repl/Manifest
new file mode 100644
index 000000000000..f784fb34c328
--- /dev/null
+++ b/app-emacs/julia-repl/Manifest
@@ -0,0 +1 @@
+DIST julia-repl-1.3.0_p20220225.tar.gz 183305 BLAKE2B 65b07101008e0548041084f50bec3022789363d8e33c6870382166c2989f56c908a7f7df378d49f55b64479d562594ff14e518a66bd36a907714214521add31f SHA512 12d9445432158c12e857c71683ea39b0bd8a76fa415ebe1d85b682d65b53c456518d88b08f98d900211c04f5d1bf12f50e4ce70ff28d4c4a657b072731968a14
diff --git a/app-emacs/julia-repl/files/50julia-repl-gentoo.el b/app-emacs/julia-repl/files/50julia-repl-gentoo.el
new file mode 100644
index 000000000000..8c76042f08d4
--- /dev/null
+++ b/app-emacs/julia-repl/files/50julia-repl-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'julia-repl-mode "julia-repl"
+ "Minor mode for interacting with a Julia REPL running inside a term." t)
+(add-hook 'julia-mode-hook 'julia-repl-mode)
diff --git a/app-emacs/julia-repl/files/julia-repl-force-compile.patch b/app-emacs/julia-repl/files/julia-repl-force-compile.patch
new file mode 100644
index 000000000000..6d7de553ce39
--- /dev/null
+++ b/app-emacs/julia-repl/files/julia-repl-force-compile.patch
@@ -0,0 +1,9 @@
+index 41df3f1..7d983f8 100644
+--- a/julia-repl.el
++++ b/julia-repl.el
+@@ -1,4 +1,4 @@
+-;;; julia-repl.el --- A minor mode for a Julia REPL -*- lexical-binding:t; no-byte-compile:t -*-
++;;; julia-repl.el --- A minor mode for a Julia REPL -*- lexical-binding:t; -*-
+
+ ;; Copyright (C) 2016 Tamas K. Papp
+ ;; Author: Tamas Papp <tkpapp@gmail.com>
diff --git a/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild b/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
new file mode 100644
index 000000000000..b52af57974bd
--- /dev/null
+++ b/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=6c1d63511fb2b3b3f2e342eff6a375d78be6c12c
+NEED_EMACS=25.1
+
+inherit optfeature elisp
+
+DESCRIPTION="Run an inferior Julia REPL in a terminal inside Emacs"
+HOMEPAGE="https://github.com/tpapp/julia-repl/"
+SRC_URI="https://github.com/tpapp/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-emacs/s"
+RDEPEND="
+ ${BDEPEND}
+ app-emacs/julia-mode
+"
+
+DOCS=( CHANGELOG.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-force-compile.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l ert -l ./${PN}-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ rm ./${PN}-tests.el || die
+
+ elisp_src_install
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "running Julia inside VTerm" app-emacs/vterm
+}
diff --git a/app-emacs/julia-repl/metadata.xml b/app-emacs/julia-repl/metadata.xml
new file mode 100644
index 000000000000..0e443214e73b
--- /dev/null
+++ b/app-emacs/julia-repl/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This is a minor mode for interacting with a Julia REPL running inside
+ Emacs. The julia process is started in an ANSI terminal (term), which
+ allows text formatting and colors, and interaction with the help system and
+ the debugger.
+ It is recommended that you use this minor mode with julia-mode.
+ </longdescription>
+ <upstream>
+ <changelog>
+ https://raw.githubusercontent.com/tpapp/julia-repl/master/CHANGELOG.md
+ </changelog>
+ <bugs-to>https://github.com/tpapp/julia-repl/issues/</bugs-to>
+ <remote-id type="github">tpapp/julia-repl</remote-id>
+ </upstream>
+</pkgmetadata>