summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-12-16 21:08:08 +0100
committerUlrich Müller <ulm@gentoo.org>2019-12-16 21:14:56 +0100
commitaceea460967eca31691e434caa22dcbecec392bf (patch)
tree9b657d4fcbeea9ade937829cf738f072f914ce02 /app-emacs/websocket/websocket-1.12.ebuild
parentapp-emacs/rust-mode: Remove old. (diff)
downloadgentoo-aceea460967eca31691e434caa22dcbecec392bf.tar.gz
gentoo-aceea460967eca31691e434caa22dcbecec392bf.tar.bz2
gentoo-aceea460967eca31691e434caa22dcbecec392bf.zip
app-emacs/websocket: Version bump to 1.12.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/websocket/websocket-1.12.ebuild')
-rw-r--r--app-emacs/websocket/websocket-1.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/websocket/websocket-1.12.ebuild b/app-emacs/websocket/websocket-1.12.ebuild
new file mode 100644
index 000000000000..c512baa9f3c7
--- /dev/null
+++ b/app-emacs/websocket/websocket-1.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A websocket implementation in elisp"
+HOMEPAGE="https://github.com/ahyatt/emacs-websocket"
+SRC_URI="https://github.com/ahyatt/emacs-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/emacs-${P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile websocket.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l websocket-test \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} websocket.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org websocket-functional-test.el testserver.py
+}