summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-12 23:38:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-12 23:49:40 +0200
commiteb8d8494fe657bac6748a18c26aa327e5571be5f (patch)
tree53943a161bee5f190e2fdf74d920dcd1642bf38e /app-emacs
parentapp-emacs/gruvbox-theme: enable live (diff)
downloadgentoo-eb8d8494fe657bac6748a18c26aa327e5571be5f.tar.gz
gentoo-eb8d8494fe657bac6748a18c26aa327e5571be5f.tar.bz2
gentoo-eb8d8494fe657bac6748a18c26aa327e5571be5f.zip
app-emacs/gruvbox-theme: add live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild b/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild
new file mode 100644
index 000000000000..55a2a4c34f3a
--- /dev/null
+++ b/app-emacs/gruvbox-theme/gruvbox-theme-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Gruvbox is a retro groove color scheme, now in Emacs"
+HOMEPAGE="https://github.com/greduan/emacs-theme-gruvbox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/greduan/emacs-theme-gruvbox.git"
+else
+ SRC_URI="https://github.com/greduan/emacs-theme-gruvbox/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-theme-gruvbox-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/autothemer-0.2
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"