summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-05-31 17:02:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-05-31 17:03:05 -0500
commitb154014efbc06d43e6a122f1f6566c802bbdc125 (patch)
treeec702d9c35165b8645ed8874dec3afe1a530243f /app-emulation/diskimage-builder
parentsys-cluster/heat: 9.0.4 and 10.0.1 stable amd64 and x86 with cleanup (diff)
downloadgentoo-b154014efbc06d43e6a122f1f6566c802bbdc125.tar.gz
gentoo-b154014efbc06d43e6a122f1f6566c802bbdc125.tar.bz2
gentoo-b154014efbc06d43e6a122f1f6566c802bbdc125.zip
app-emulation/diskimage-builder: 2.15.0 bup
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.15.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 0ea35a462075..504a1e5bc855 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-2.14.1.tar.gz 348188 BLAKE2B 3d751fc3f05578a7b5296c8b7ebde1b8dd0a38e40dc378fded93faa34c623db2abeac53c72048ce7ebd5747eb50a4f9e5525baba800adc4b2c1925f31a1dce0b SHA512 d056c89e78b3f42ccc5ced2dfdd9ac1c50ecdcb6861f81bdb3cd3c9d624fbba89c2a2b9ed08850dd79ff9fdf47fcaa3d3519b32f909bd1b0b12bbacf4d9ab758
+DIST diskimage-builder-2.15.0.tar.gz 350322 BLAKE2B 6eca37edbf556bf8aece189117510946dcc687af17060add95a1efd1a9136f16597b2f9ef3b0beead0079566c83e19683eb0019ea290fa3b5cc5b132aa97eca8 SHA512 ffc0a1938c02140144d3e057f24c051a620f66ca400cc65c7d1743adcb94d1e1f3c99811addac0a9fb47fc81a73713c2edc2d26f7526098e69b05fb9144176ea
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.15.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.15.0.ebuild
new file mode 100644
index 000000000000..1495264437fd
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.15.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"