summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/softgun/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/softgun/files')
-rw-r--r--app-emulation/softgun/files/softgun-0.21-make.patch68
-rw-r--r--app-emulation/softgun/files/softgun-0.22-make.patch75
2 files changed, 143 insertions, 0 deletions
diff --git a/app-emulation/softgun/files/softgun-0.21-make.patch b/app-emulation/softgun/files/softgun-0.21-make.patch
new file mode 100644
index 000000000000..bb3ded406a0a
--- /dev/null
+++ b/app-emulation/softgun/files/softgun-0.21-make.patch
@@ -0,0 +1,68 @@
+--- softgun-0.21/config.mk
++++ softgun-0.21/config.mk
+@@ -9,7 +9,7 @@ bindir=$(prefix)/bin
+ libdir=$(prefix)/lib/softgun/
+
+ #CFLAGS=-Wall -pg -O1 -g
+-CFLAGS=-Wall -O9 -g -fomit-frame-pointer -fno-strict-overflow -Wstrict-overflow=3 -Wno-unused-but-set-variable
++CFLAGS+=-fno-strict-overflow -Wstrict-overflow=3 -Wno-unused-but-set-variable
+ DEFS=-D_GNU_SOURCE
+ INCLUDES:=-I$(top_srcdir) -I.
+
+@@ -19,13 +19,13 @@
+ SHAREDLDFLAGS=-nostdlib -shared
+ CYGWIN=$(findstring CYGWIN,$(shell uname))
+ ifeq ($(shell uname),Linux)
+-LDFLAGS=-lpthread -lrt -lm -lz -lasound
++LDLIBS=-lpthread -ldl -lrt -lm -lz -lasound
+ else
+ ifeq ($(shell uname),FreeBSD)
+- LDFLAGS=-lpthread -lm -lz -lSDL
++ LDLIBS=-lpthread -lm -lz -lSDL
+ else
+ ifeq ($(CYGWIN),CYGWIN)
+- LDFLAGS=-lpthread -lrt -lm -lz
++ LDLIBS=-lpthread -lrt -lm -lz
+ else
+ $(error "Unknown architecture $(shell uname)")
+ endif
+--- softgun-0.21/Makefile
++++ softgun-0.21/Makefile
+@@ -116,7 +116,7 @@
+
+
+ softgun: $(OBJS)
+- $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ $(LDLIBS)
+
+ boards/libboards.a:
+ $(MAKE) -C boards libboards.a
+--- softgun-0.21/printer/module.mk
++++ softgun-0.21/printer/module.mk
+@@ -5,5 +5,5 @@
+ INSTALL_BINS += pcl3gui2png
+
+ pcl3gui2png: $(PRINTER_OBJS) printer/pcl3gui2png.c
+- $(CC) -o $@ $(PRINTER_OBJS) printer/pcl3gui2png.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+--- softgun-0.21/tools/Makefile
++++ softgun-0.21/tools/Makefile
+@@ -2,7 +2,7 @@ include ../config.mk
+
+ ifeq ($(shell uname),Linux)
+ sg_tunctl: tunctl.c
+- $(CC) $(CFLAGS) tunctl.c -o sg_tunctl
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+ install:
+ install -m 0755 sg_tunctl $(bindir)
+@@ -14,7 +14,7 @@ install:
+ endif
+
+ to_c_array: to_c_array.c
+- $(CC) $(CFLAGS) to_c_array.c -o to_c_array
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+
+ clean:
diff --git a/app-emulation/softgun/files/softgun-0.22-make.patch b/app-emulation/softgun/files/softgun-0.22-make.patch
new file mode 100644
index 000000000000..9d1ea9b38e0d
--- /dev/null
+++ b/app-emulation/softgun/files/softgun-0.22-make.patch
@@ -0,0 +1,75 @@
+--- softgun-0.22/config.mk
++++ softgun-0.22/config.mk
+@@ -9,7 +9,7 @@ bindir=$(prefix)/bin
+ libdir=$(prefix)/lib/softgun/
+
+ #CFLAGS=-Wall -pg -O0 -DPROFILE
+-CFLAGS=-Wall -O9 -g -fomit-frame-pointer -fno-strict-overflow -Wstrict-overflow=3 -Wno-unused-but-set-variable
+-DEFS=-D_GNU_SOURCE
++CFLAGS+=-Wall -fno-strict-overflow -Wstrict-overflow=3 -Wno-unused-but-set-variable -fno-strict-aliasing
++DEFS=$(CPPFLAGS) -D_GNU_SOURCE
+ INCLUDES:=-I$(top_srcdir) -I.
+
+@@ -17,15 +17,16 @@ INCLUDES:=-I$(top_srcdir) -I.
+ # to omit stack protection symbol in object file
+ SHAREDCFLAGS=-fPIC -nostdlib -D_SHARED_
+ SHAREDLDFLAGS=-nostdlib -shared
+-CYGWIN=$(findstring CYGWIN,$(shell uname))
+-ifeq ($(shell uname),Linux)
+-LDFLAGS=-lpthread -lrt -lm -lz -lasound
++UNAME=$(shell uname)
++CYGWIN=$(findstring CYGWIN,$(UNAME))
++ifeq ($(UNAME),Linux)
++LDLIBS=-lpthread -ldl -lrt -lm -lz -lasound
+ else
+- ifeq ($(shell uname),FreeBSD)
+- LDFLAGS=-lpthread -lm -lz -lSDL
++ ifeq ($(UNAME),FreeBSD)
++ LDLIBS=-lpthread -lm -lz -lSDL
+ else
+ ifeq ($(CYGWIN),CYGWIN)
+- LDFLAGS=-lpthread -lrt -lm -lz
++ LDLIBS=-lpthread -lrt -lm -lz
+ else
+ $(error "Unknown architecture $(shell uname)")
+ endif
+--- softgun-0.22/Makefile
++++ softgun-0.22/Makefile
+@@ -116,7 +116,7 @@
+
+
+ softgun: $(OBJS)
+- $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ $(LDLIBS)
+
+ boards/libboards.a:
+ $(MAKE) -C boards libboards.a
+--- softgun-0.22/printer/module.mk
++++ softgun-0.22/printer/module.mk
+@@ -5,5 +5,5 @@
+ INSTALL_BINS += pcl3gui2png
+
+ pcl3gui2png: $(PRINTER_OBJS) printer/pcl3gui2png.c
+- $(CC) -o $@ $(PRINTER_OBJS) printer/pcl3gui2png.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+--- softgun-0.22/tools/Makefile
++++ softgun-0.22/tools/Makefile
+@@ -2,7 +2,7 @@ include ../config.mk
+
+ ifeq ($(shell uname),Linux)
+ sg_tunctl: tunctl.c
+- $(CC) $(CFLAGS) tunctl.c -o sg_tunctl
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+ install:
+ install -m 0755 sg_tunctl $(bindir)
+@@ -14,7 +14,7 @@ install:
+ endif
+
+ to_c_array: to_c_array.c
+- $(CC) $(CFLAGS) to_c_array.c -o to_c_array
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+
+ clean: