summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-11-02 12:57:45 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-11-02 13:05:49 +0100
commit6ae08f39d5f2eb0896d7ec699365dfa76aaade83 (patch)
treee3984c0cb2735c94b09387e7674419bb5e285288 /app-emulation
parentdev-libs/cyberjack: drop 3.99.5_p16 (diff)
downloadgentoo-6ae08f39d5f2eb0896d7ec699365dfa76aaade83.tar.gz
gentoo-6ae08f39d5f2eb0896d7ec699365dfa76aaade83.tar.bz2
gentoo-6ae08f39d5f2eb0896d7ec699365dfa76aaade83.zip
app-emulation/faudio: add 24.11
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/faudio/Manifest1
-rw-r--r--app-emulation/faudio/faudio-24.11.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/faudio/Manifest b/app-emulation/faudio/Manifest
index 3cfb7fdff165..6322ea5a1fd9 100644
--- a/app-emulation/faudio/Manifest
+++ b/app-emulation/faudio/Manifest
@@ -1 +1,2 @@
DIST faudio-24.10.tar.gz 1125385 BLAKE2B 1179139403621302c238b1ba4dfd691b64541c2b23919cfb86f9cad587e1fbd68be18c62c00fc3a9c408d7c580e2ce63392d362ad32a60957bc102b5a1189c51 SHA512 e0b2031ba8452aa0696bc841013db5558c97f87a0071cf5fb48dd668363980d6d7d1adbc22d051e5019f32ee4aaf5553ebb80d37b87e9bcde153b828be5ff127
+DIST faudio-24.11.tar.gz 1126428 BLAKE2B 47dc75a85a247079cabd1920dc63a2932bedcdb848bcf3e0f7d6ce8b093c53dc16af2329bd21ab92578378a0b4ba5e494a9e97fd0b54f80a7c1a29dabeadc008 SHA512 7a2c8c1ea7e3ab31211dedbd54cd60d06ddb0ada5ae00c7eca3bbf71cee4701ecbb232313f672018e28e472285e0862658ad1fa84f01fd8e77deefb47e47d080
diff --git a/app-emulation/faudio/faudio-24.11.ebuild b/app-emulation/faudio/faudio-24.11.ebuild
new file mode 100644
index 000000000000..e372ae484496
--- /dev/null
+++ b/app-emulation/faudio/faudio-24.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Accuracy-focused XAudio reimplementation for open platforms"
+HOMEPAGE="https://fna-xna.github.io/"
+SRC_URI="https://github.com/FNA-XNA/FAudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FAudio-${PV}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dumpvoices test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/libsdl2[sound]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cppflags -D_DEFAULT_SOURCE # usleep() in tests
+ use debug || append-cppflags -DFAUDIO_DISABLE_DEBUGCONFIGURATION
+
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDUMP_VOICES=$(usex dumpvoices)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ einfo "Running faudio_tests, this may take some time without output..."
+ SDL_AUDIODRIVER=dummy "${BUILD_DIR}"/faudio_tests || die
+}