summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-10-04 07:09:19 -0700
committerMichał Górny <mgorny@gentoo.org>2022-10-14 06:15:47 +0200
commit1692c261b7393b5dfee906ae505b06261a494137 (patch)
tree196ebca57277d75e0c0bf62ba70ac2cbd2e5cfa0 /app-eselect
parentdev-util/dialog: Stabilize 1.3.20220728 ppc, #877055 (diff)
downloadgentoo-1692c261b7393b5dfee906ae505b06261a494137.tar.gz
gentoo-1692c261b7393b5dfee906ae505b06261a494137.tar.bz2
gentoo-1692c261b7393b5dfee906ae505b06261a494137.zip
app-eselect/eselect-sh: Add 0.5.0
Adds support to set lksh as /bin/sh which preferred /bin/sh for mksh according to upstream. Using mksh as /bin/sh is only POSIX on 32-bit systems, but some may still prefer it as POSIX requires some undefined behavior which is respected with lksh. Closes: https://github.com/gentoo/gentoo/pull/20787 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/27615 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild21
-rw-r--r--app-eselect/eselect-sh/files/sh.eselect-0.5.013
2 files changed, 34 insertions, 0 deletions
diff --git a/app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild b/app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild
new file mode 100644
index 000000000000..0516ae327ad5
--- /dev/null
+++ b/app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manages the /bin/sh (POSIX shell) symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/sh.eselect-${PV} sh.eselect
+}
diff --git a/app-eselect/eselect-sh/files/sh.eselect-0.5.0 b/app-eselect/eselect-sh/files/sh.eselect-0.5.0
new file mode 100644
index 000000000000..aa0f3c08494f
--- /dev/null
+++ b/app-eselect/eselect-sh/files/sh.eselect-0.5.0
@@ -0,0 +1,13 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /bin/sh (POSIX shell) implementations"
+MAINTAINER="mgorny@gentoo.org"
+VERSION="0.5.0"
+
+SYMLINK_PATH=/bin/sh
+SYMLINK_TARGETS=( bash dash lksh mksh )
+SYMLINK_DESCRIPTION='POSIX shell'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink