summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-05 03:21:37 +0100
committerSam James <sam@gentoo.org>2024-10-05 03:21:37 +0100
commitd7386e01cee302b22b0d2c12f7d7083dc54538b0 (patch)
tree3f6723fd130b59795c48b68fac567f1764cfaed5 /app-forensics
parentapp-forensics/aflplusplus: fix man page (diff)
downloadgentoo-d7386e01cee302b22b0d2c12f7d7083dc54538b0.tar.gz
gentoo-d7386e01cee302b22b0d2c12f7d7083dc54538b0.tar.bz2
gentoo-d7386e01cee302b22b0d2c12f7d7083dc54538b0.zip
app-forensics/aflplusplus: add 4.21c
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/aflplusplus/Manifest2
-rw-r--r--app-forensics/aflplusplus/aflplusplus-4.21c.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/app-forensics/aflplusplus/Manifest b/app-forensics/aflplusplus/Manifest
index bf9dc0fa2be8..f96d174d16ab 100644
--- a/app-forensics/aflplusplus/Manifest
+++ b/app-forensics/aflplusplus/Manifest
@@ -1,2 +1,4 @@
DIST aflplusplus-4.07c-patches.tar.xz 4788 BLAKE2B de109198fbabfce2554459fee6a14f66002a952f5584ff265a6ff7d7646f520ed53a6d9c8c125a05eb5a4aa0c1cc675dca82647ad4c0965cdab10d3aa2f09467 SHA512 0ea4279b261d55cf209e32ca4b7fd7dc1181ec902dd7e4c7f36854d84f14037e643a543dcbb849927b41919c527303fc5877c9fab5b09c8988fbfab499b8f8bc
DIST aflplusplus-4.08c.tar.gz 2894794 BLAKE2B 5576ec54969c7ae10b05fe10320581b348f989c1bc412bd63b2ca7ecb3bd1782a90c2660d971375667f6dd820f9035d7abb2207f59a1aaa5e7640d352eaa5757 SHA512 52c35ed544db8be778b79a64977fcc74092b541c4c07a788b20f4b9e8db95ff9c52c997ebf6f5a1056f962f3551df06a5eca02679bc2b71bb9d8944c1f77984a
+DIST aflplusplus-4.21c-patches.tar.xz 4932 BLAKE2B 8d53291a6d26ecc3d08fb4ca2711544e16c393def9fcb383d4eeb1d67d6bcd531788907ebeac2413e7fed5af5d56f363c6c4d766453e1d8de482cb6d285164ca SHA512 10322ed8d4549ccd2ee85fee00ffea712195858a004344424c31ebe4e4e8d3caf03f0d81d5cb38365418ee1e96288ba44504cb41a66644076e2cb46527f111fc
+DIST aflplusplus-4.21c.tar.gz 3004235 BLAKE2B c182260ba25a8a7a87b91ece5b3ea6aafba09b3361259361d9be24b7c5dd90430403a3170ed9397edaa714a45f62de26f324aab005a27a44fffce2708bb366e5 SHA512 cb58d58561ac814e07e9b5b735fade42b977fb1b92a63f1d7a66a5809203e83acf805ccfdc8ce29c9a3b374a189690010ca3d8ae20e261680751cea3c4841777
diff --git a/app-forensics/aflplusplus/aflplusplus-4.21c.ebuild b/app-forensics/aflplusplus/aflplusplus-4.21c.ebuild
new file mode 100644
index 000000000000..f1979de0556c
--- /dev/null
+++ b/app-forensics/aflplusplus/aflplusplus-4.21c.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_COMPAT=( {15..19} )
+PYTHON_COMPAT=( python3_{10..13} )
+inherit toolchain-funcs llvm-r1 optfeature python-single-r1
+
+AFL_PATCHSET="${PN}-4.21c-patches"
+DESCRIPTION="Fork of AFL, the popular compile-time instrumentation fuzzer"
+HOMEPAGE="https://github.com/AFLplusplus/AFLplusplus"
+SRC_URI="https://github.com/AFLplusplus/AFLplusplus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${AFL_PATCHSET}.tar.xz"
+S="${WORKDIR}"/AFLplusplus-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests involve heavy use of LD_PRELOAD in some cases
+# This isn't compatible with sandbox
+RESTRICT="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(llvm_gen_dep '
+ sys-devel/clang:${LLVM_SLOT}=
+ sys-devel/llvm:${LLVM_SLOT}=
+ ')
+ !app-forensics/afl
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )
+"
+
+QA_FLAGS_IGNORED="
+ usr/lib.*/afl/afl-gcc-cmplog-pass.so
+ usr/lib.*/afl/afl-gcc-cmptrs-pass.so
+"
+QA_PREBUILT="usr/share/afl/testcases/others/elf/small_exec.elf"
+
+PATCHES=(
+ "${WORKDIR}"/${AFL_PATCHSET}
+)
+
+pkg_setup() {
+ llvm-r1_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+mymake() {
+ # afl-fuzz spews garbage to stdout if the environment contains any
+ # variables whose name beginning with USE_ (including the underscore),
+ # regardless of their value (even if empty!). The ebuild environment
+ # contains several such variables and the garbage that gets printed
+ # ends up in the generated man page.
+ #
+ # We can work around the problem by unsetting all these variables when
+ # running make.
+ local badvars=("${!USE_@}")
+
+ env "${badvars[@]/#/-u}" emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CFLAGS_FLTO="" \
+ PREFIX="${EPREFIX}/usr" \
+ HELPER_PATH="${EPREFIX}/usr/$(get_libdir)/afl" \
+ DOC_PATH="${EPREFIX}/usr/share/doc/${PF}" \
+ MAN_PATH="${EPREFIX}/usr/share/man/man8" \
+ "$@"
+}
+
+src_compile() {
+ mymake
+}
+
+src_test() {
+ mymake test
+}
+
+src_install() {
+ mymake DESTDIR="${D}" install
+ dostrip -x /usr/share/afl/testcases/
+}
+
+pkg_postinst() {
+ # TODO: Any others?
+ optfeature "fuzzing with AFL_USE_ASAN" sys-libs/compiler-rt-sanitizers[asan]
+ optfeature "fuzzing with AFL_USE_MSAN" sys-libs/compiler-rt-sanitizers[msan]
+}