summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2023-12-06 13:56:12 +0800
committerYixun Lan <dlan@gentoo.org>2023-12-25 11:50:37 +0000
commit2a8553bbb2df7b3a6165d0edf54eeb600732607d (patch)
treedcec9621b4e08ff2ed070851432d4d881e2e3750 /app-i18n/fcitx-lua
parentapp-i18n/libime: new package, add 1.1.3 (diff)
downloadgentoo-2a8553bbb2df7b3a6165d0edf54eeb600732607d.tar.gz
gentoo-2a8553bbb2df7b3a6165d0edf54eeb600732607d.tar.bz2
gentoo-2a8553bbb2df7b3a6165d0edf54eeb600732607d.zip
app-i18n/fcitx-lua: new package, add 5.0.11
fcitx-lua is lua support for fcitx5. It is an optional dependency of app-i18n/fcitx-chinese-addons. Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n/fcitx-lua')
-rw-r--r--app-i18n/fcitx-lua/Manifest1
-rw-r--r--app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild46
-rw-r--r--app-i18n/fcitx-lua/metadata.xml31
3 files changed, 78 insertions, 0 deletions
diff --git a/app-i18n/fcitx-lua/Manifest b/app-i18n/fcitx-lua/Manifest
new file mode 100644
index 000000000000..8fefb82b8810
--- /dev/null
+++ b/app-i18n/fcitx-lua/Manifest
@@ -0,0 +1 @@
+DIST fcitx-lua-5.0.11.tar.xz 34320 BLAKE2B 9140e96362d8a294149028946c3072c195145ccdf4f350d438904305dcca3fb4b3c70f205bd2ff83f700ae8822b2bd99efc5ec77009f5636c72d7ea10d6d15f4 SHA512 c69391efb910cc476608022d15d6e06323bef6cf50c9c63297827969a796b153ad82c7953c3a8fc4432bb887323aa15456d4a8fc246814e165efa54307fa7efe
diff --git a/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild b/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild
new file mode 100644
index 000000000000..4dc09a6886b7
--- /dev/null
+++ b/app-i18n/fcitx-lua/fcitx-lua-5.0.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{3,4} )
+
+MY_PN="fcitx5-lua"
+
+inherit cmake lua-single xdg
+
+DESCRIPTION="Lua support for fcitx"
+HOMEPAGE="https://github.com/fcitx/fcitx5-lua"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dlopen test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ app-i18n/fcitx:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ lua-single_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DLOPEN=$(usex dlopen)
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/app-i18n/fcitx-lua/metadata.xml b/app-i18n/fcitx-lua/metadata.xml
new file mode 100644
index 000000000000..152073f668d9
--- /dev/null
+++ b/app-i18n/fcitx-lua/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fcitx/fcitx5-lua</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Lua support for fcitx.
+ It tries to support lua in fcitx in two ways.
+ 1. An addon loader for lua, which supports Type=Lua addon.
+ 2. The googlepinyin api, which is provided by imeapi addon.
+ You may put your lua file under
+ $HOME/.local/share/fcitx5/lua/imeapi/extensions
+ to make the addon find your scripts.
+ </longdescription>
+ <use>
+ <flag name="dlopen">Use dlopen to load lua library</flag>
+ </use>
+</pkgmetadata>