summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-22 11:23:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-22 11:25:22 +0200
commit4353b914b080299ef3ea0641ba96ed5177fadd2b (patch)
treeee59505725ec3e5e52c9999a6e91a7b7a94c8c2c /app-misc/siegfried/siegfried-1.11.1_rc4.ebuild
parentsys-devel/clang: llvm/lib/Transforms/Hello is gone (diff)
downloadgentoo-4353b914b080299ef3ea0641ba96ed5177fadd2b.tar.gz
gentoo-4353b914b080299ef3ea0641ba96ed5177fadd2b.tar.bz2
gentoo-4353b914b080299ef3ea0641ba96ed5177fadd2b.zip
app-misc/siegfried: Bump to 1.11.1_rc4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc/siegfried/siegfried-1.11.1_rc4.ebuild')
-rw-r--r--app-misc/siegfried/siegfried-1.11.1_rc4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/siegfried/siegfried-1.11.1_rc4.ebuild b/app-misc/siegfried/siegfried-1.11.1_rc4.ebuild
new file mode 100644
index 000000000000..a6e8b8e33da2
--- /dev/null
+++ b/app-misc/siegfried/siegfried-1.11.1_rc4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+MY_P=${P/_/-}
+DESCRIPTION="Signature-based file format identification"
+HOMEPAGE="
+ https://www.itforarchivists.com/siegfried/
+ https://github.com/richardlehane/siegfried/
+"
+SRC_URI="
+ https://github.com/richardlehane/siegfried/archive/v${PV/_/-}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+ https://github.com/richardlehane/siegfried/releases/download/v${PV/_/-}/data_${PV//[._]/-}.zip
+ -> ${MY_P}-data.zip
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${P}.deps.tar.xz
+ "
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+# vendored deps
+LICENSE+=" BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ !app-misc/dfshow
+"
+
+src_compile() {
+ go build -v -work -x "${S}"/cmd/roy || die
+ go build -v -work -x "${S}"/cmd/sf || die
+}
+
+src_test() {
+ cp "${WORKDIR}/siegfried/fddXML.zip" cmd/roy/data || die
+ go test -v "${S}"/cmd/roy || die
+ go test -v "${S}"/cmd/sf || die
+}
+
+src_install() {
+ dobin roy sf
+ insinto /usr/share/siegfried
+ doins "${WORKDIR}/siegfried/default.sig"
+}