summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/scribus/files/scribus-1.5.0-docdir.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/scribus/files/scribus-1.5.0-docdir.patch')
-rw-r--r--app-office/scribus/files/scribus-1.5.0-docdir.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-office/scribus/files/scribus-1.5.0-docdir.patch b/app-office/scribus/files/scribus-1.5.0-docdir.patch
new file mode 100644
index 000000000000..2ff316a91b57
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.5.0-docdir.patch
@@ -0,0 +1,42 @@
+ CMakeLists.txt | 28 +++++++++++++++-------------
+ 1 file changed, 15 insertions(+), 13 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 29d66f3..1c08cdd 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -244,19 +244,21 @@ ELSE()
+ ENDIF()
+
+ #SHARE - use the default on Apple as TAG_VERSION is empty
+-IF(WIN32 OR OS2)
+- SET(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/")
+-ELSE (WIN32 OR OS2)
+- IF(TAG_VERSION OR BUILD_OSX_BUNDLE)
+- SET(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}${TAG_VERSION}/")
+- ELSE(TAG_VERSION OR BUILD_OSX_BUNDLE)
+- IF(NOT WANT_VERSIONING)
+- SET(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}/")
+- ELSE(NOT WANT_VERSIONING)
+- SET(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}-${VERSION}/")
+- ENDIF(NOT WANT_VERSIONING)
+- ENDIF (TAG_VERSION OR BUILD_OSX_BUNDLE)
+-ENDIF (WIN32 OR OS2)
++IF(NOT DOCDIR)
++ IF(WIN32 OR OS2)
++ SET(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/")
++ ELSE (WIN32 OR OS2)
++ IF(TAG_VERSION OR BUILD_OSX_BUNDLE)
++ SET(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}${TAG_VERSION}/")
++ ELSE(TAG_VERSION OR BUILD_OSX_BUNDLE)
++ IF(NOT WANT_VERSIONING)
++ SET(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}/")
++ ELSE(NOT WANT_VERSIONING)
++ SET(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}-${VERSION}/")
++ ENDIF(NOT WANT_VERSIONING)
++ ENDIF (TAG_VERSION OR BUILD_OSX_BUNDLE)
++ ENDIF (WIN32 OR OS2)
++ENDIF(NOT DOCDIR)
+ IF(NOT IS_ABSOLUTE ${DOCDIR})
+ ADD_DEFINITIONS("-DDOCDIR=\\\"${CMAKE_INSTALL_PREFIX}/${DOCDIR}\\\"")
+ ELSE()