summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-02-07 11:07:03 -0500
committerMike Gilbert <floppym@gentoo.org>2020-02-07 11:07:24 -0500
commit17c85a06ac2f352567348a04c4f682c950105417 (patch)
tree89ab9292bfdbf69cfefce3530f08580210c28cd7 /app-shells/ksh/ksh-2020.0.0-r1.ebuild
parentapp-text/discount: fix build of libmarkdown (diff)
downloadgentoo-17c85a06ac2f352567348a04c4f682c950105417.tar.gz
gentoo-17c85a06ac2f352567348a04c4f682c950105417.tar.bz2
gentoo-17c85a06ac2f352567348a04c4f682c950105417.zip
app-shells/ksh: add fix for CVE-2019-14868
Bug: https://bugs.gentoo.org/708618 Package-Manager: Portage-2.3.86_p1, Repoman-2.3.20_p43 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-shells/ksh/ksh-2020.0.0-r1.ebuild')
-rw-r--r--app-shells/ksh/ksh-2020.0.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-shells/ksh/ksh-2020.0.0-r1.ebuild b/app-shells/ksh/ksh-2020.0.0-r1.ebuild
new file mode 100644
index 000000000000..3c4891ea637e
--- /dev/null
+++ b/app-shells/ksh/ksh-2020.0.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/att/ast"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ MY_PV="${PV/_/-}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/att/ast/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="https://github.com/att/ast"
+
+LICENSE="CPL-1.0 EPL-1.0"
+SLOT="0"
+
+RDEPEND="!app-shells/pdksh"
+
+PATCHES=(
+ "${FILESDIR}"/ksh-2020.0.0-ensure-user-set.patch
+ "${FILESDIR}"/ksh-2020.0.0-skip-api-test.patch
+ "${FILESDIR}"/CVE-2019-14868.patch
+)
+
+src_test() {
+ # https://bugs.gentoo.org/702570
+ addwrite /proc/self
+ local cmd=(
+ meson test
+ -C "${BUILD_DIR}"
+ --num-processes "$(makeopts_jobs ${NINJAOPTS:-${MAKEOPTS}})"
+ )
+ echo "${cmd[@]}" >&2
+ # https://github.com/att/ast/issues/1392
+ env -u T "${cmd[@]}" || die
+}
+
+src_install() {
+ meson_src_install
+ dodir /bin
+ mv "${ED}/usr/bin/ksh" "${ED}/bin/ksh" || die
+}