summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-09 00:21:00 +0000
committerSam James <sam@gentoo.org>2025-01-09 00:21:35 +0000
commit6cf9f15700ecffad5ae8b6dc2d8365881848a47d (patch)
treefab52efb9561de13c5adf06c20a11d5f8474b032 /app-shells
parentapp-shells/bashdb: add github upstream metadata (diff)
downloadgentoo-6cf9f15700ecffad5ae8b6dc2d8365881848a47d.tar.gz
gentoo-6cf9f15700ecffad5ae8b6dc2d8365881848a47d.tar.bz2
gentoo-6cf9f15700ecffad5ae8b6dc2d8365881848a47d.zip
app-shells/bashdb: add 5.1_pre20240617
bashdb for newer bash versions doesn't (yet?) have tags, so we take snapshots. Make sure to pick the right branch. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bashdb/Manifest1
-rw-r--r--app-shells/bashdb/bashdb-5.1_pre20240617.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-shells/bashdb/Manifest b/app-shells/bashdb/Manifest
index 591e254211b6..0e3336423438 100644
--- a/app-shells/bashdb/Manifest
+++ b/app-shells/bashdb/Manifest
@@ -1,2 +1,3 @@
DIST bashdb-4.4-1.0.0-missing-test-files.tar.xz 996 BLAKE2B 7ea67884cceda11559cf49355645cad2cfd485537643ad2fa05398518f498163596b6f591756bedd0e7b7e013fed3c6a031e245d15cd0cf316d42ef4f5c8b3e6 SHA512 e19d41569c2001ce026e4c5f80cc21c81651ff9980be059236c45e215162769ceda266eb46aa4199000e377c0bb53dec98fa1b7c5290459c412f21329b3589a5
DIST bashdb-5.0-1.1.2.tar.bz2 574210 BLAKE2B 6de1cac2cb66022f60ab7f0385361762fedee56c26729f22acb070e24a7bcf317700fb5db314c1592b8f9ccf9f7d07bfc80afd5fc88a753d0ad2954325a7f078 SHA512 32ff6d315e8cf9d59485802d5284fde53fa2d9f40ec238428a479f8a1ed1359e9bea2946b192b78534e7ac835491d5d64d73f536c8dfa93583b4c6d55d4d4545
+DIST bashdb-5.1_pre20240617.gh.tar.gz 690536 BLAKE2B b8c736ea16f90c14ebcbe06ae6dcdcc8187161e94ca5672f9078366161afec77bd54e95f0782ec4204f6997b173844f288d9cd39a03539e83447fcdc33cc6545 SHA512 748de6d3a7a30ce59269ec953f3d2ee71d50a92038001f3a74ef758225d77de6db906945936a20439869442ac995001ef26c394050d6e73f5a1c288022faaaec
diff --git a/app-shells/bashdb/bashdb-5.1_pre20240617.ebuild b/app-shells/bashdb/bashdb-5.1_pre20240617.ebuild
new file mode 100644
index 000000000000..aa4a37d1a14e
--- /dev/null
+++ b/app-shells/bashdb/bashdb-5.1_pre20240617.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-${PV:0:3}-${PV:4}"
+DESCRIPTION="bash source code debugging"
+HOMEPAGE="http://bashdb.sourceforge.net/"
+
+if [[ ${PV} == *_pre* ]] ; then
+ inherit autotools
+
+ # bashdb for newer bash versions doesn't (yet?) have tags, so we
+ # take snapshots. Make sure to pick the right branch.
+ BASHDB_COMMIT="11150b3bee22215632143942ade99b5f2441c4ca"
+ SRC_URI="
+ https://github.com/Trepan-Debuggers/bashdb/archive/${BASHDB_COMMIT}.tar.gz -> ${P}.gh.tar.gz
+ "
+ S="${WORKDIR}"/${PN}-${BASHDB_COMMIT}
+else
+ SRC_URI="
+ https://downloads.sourceforge.net/bashdb/${MY_P}.tar.bz2
+ "
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-shells/bash:${PV:0:3}"
+RDEPEND="${DEPEND}"
+
+# test-bug-loc fails with formatting differences
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *_pre* ]] && eautoreconf
+
+ # We don't install this, so don't bother building it. #468044
+ sed -i 's:texi2html:true:' doc/Makefile.in || die
+}
+
+src_configure() {
+ # This path matches the bash sources. If we ever change bash,
+ # we'll probably have to change this to match (bug #591994).
+ CONFIG_SHELL="${BROOT}"/bin/bash econf \
+ --with-bash="${EPREFIX}"/bin/bash-${PV:0:3} \
+ --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
+}