summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandy Barlow <randy@electronsweatshop.com>2024-12-08 11:11:00 -0500
committerJoonas Niilola <juippis@gentoo.org>2025-01-03 19:06:57 +0200
commitf1450d863be954e2a8f17c588370a7dfe67af2eb (patch)
treed68463b5e8841d979c04557fe363764038103b73 /app-shells
parentnet-p2p/retroshare: Patch bundled libraries, improve ebuild (diff)
downloadgentoo-f1450d863be954e2a8f17c588370a7dfe67af2eb.tar.gz
gentoo-f1450d863be954e2a8f17c588370a7dfe67af2eb.tar.bz2
gentoo-f1450d863be954e2a8f17c588370a7dfe67af2eb.zip
app-shells/starship: Use optfeature for fonts
These fonts seem to work decently well with starship in my experience, but they are not the only suitable fonts. The user can install any nerdfont they wish as described by uptsream's documentation. starship doesn't require fonts to be installed on the same machine it is running on necessarily. For example, if starship is installed on a remote system accessed via ssh, the fonts should be installed on the client machine. Signed-off-by: Randy Barlow <randy@electronsweatshop.com> Closes: https://github.com/gentoo/gentoo/pull/39636 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/starship/starship-1.21.1-r1.ebuild (renamed from app-shells/starship/starship-1.21.1.ebuild)8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-shells/starship/starship-1.21.1.ebuild b/app-shells/starship/starship-1.21.1-r1.ebuild
index d025f86408d2..d090c5a8c639 100644
--- a/app-shells/starship/starship-1.21.1.ebuild
+++ b/app-shells/starship/starship-1.21.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2024 Gentoo Authors
+# Copyright 2022-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -397,7 +397,7 @@ CRATES="
"
RUST_MIN_VER="1.80.0"
-inherit cargo
+inherit cargo optfeature
DESCRIPTION="The minimal, blazing-fast, and infinitely customizable prompt for any shell"
HOMEPAGE="https://starship.rs/"
@@ -436,3 +436,7 @@ src_install() {
cargo_src_install
dodoc README.md
}
+
+pkg_postinst() {
+ optfeature "font support" media-fonts/iosevka media-fonts/noto-emoji
+}