summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-14 23:29:58 +0000
committerSam James <sam@gentoo.org>2020-09-14 23:29:58 +0000
commit5f4e15d766417cd8b494ae1fa948562fb0b0289f (patch)
treee2ef6e08562e4e88952ea68b042b762713eb42ae /app-text/dictd
parentnet-misc/pimpd: Stabilize 0.8-r1 sparc, #740964 (diff)
downloadgentoo-5f4e15d766417cd8b494ae1fa948562fb0b0289f.tar.gz
gentoo-5f4e15d766417cd8b494ae1fa948562fb0b0289f.tar.bz2
gentoo-5f4e15d766417cd8b494ae1fa948562fb0b0289f.zip
app-text/dictd: Fix MissingTestRestrict
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/dictd')
-rw-r--r--app-text/dictd/dictd-1.12.1-r2.ebuild5
-rw-r--r--app-text/dictd/dictd-1.13.0.ebuild13
2 files changed, 10 insertions, 8 deletions
diff --git a/app-text/dictd/dictd-1.12.1-r2.ebuild b/app-text/dictd/dictd-1.12.1-r2.ebuild
index 4da9d8dbf3ae..4feb9c4a5c76 100644
--- a/app-text/dictd/dictd-1.12.1-r2.ebuild
+++ b/app-text/dictd/dictd-1.12.1-r2.ebuild
@@ -13,6 +13,7 @@ SLOT="0"
LICENSE="GPL-2 ISOC-rfc"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
IUSE="dbi judy minimal test"
+RESTRICT="!test? ( test )"
# <gawk-3.1.6 makes tests fail.
RDEPEND="
@@ -78,9 +79,9 @@ src_test() {
src_install() {
if use minimal; then
- emake DESTDIR="${D}" install.dictzip install.dict install.dictfmt
+ emake DESTDIR="${ED}" install.dictzip install.dict install.dictfmt
else
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
dodoc doc/{dicf.ms,rfc.ms,rfc.sh,rfc2229.txt}
dodoc doc/{security.doc,toc.ms}
diff --git a/app-text/dictd/dictd-1.13.0.ebuild b/app-text/dictd/dictd-1.13.0.ebuild
index 6f994838112e..79c142175876 100644
--- a/app-text/dictd/dictd-1.13.0.ebuild
+++ b/app-text/dictd/dictd-1.13.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit readme.gentoo-r1 systemd user
DESCRIPTION="Dictionary Client/Server for the DICT protocol"
@@ -13,6 +14,7 @@ SLOT="0"
LICENSE="GPL-2 ISOC-rfc"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
IUSE="dbi judy minimal test"
+RESTRICT="!test? ( test )"
# <gawk-3.1.6 makes tests fail.
RDEPEND="
@@ -22,9 +24,7 @@ RDEPEND="
dbi? ( dev-db/libdbi )
judy? ( dev-libs/judy )
"
-DEPEND="
- ${RDEPEND}
-"
+DEPEND="${RDEPEND}"
BDEPEND="
>=sys-apps/gawk-3.1.6
virtual/yacc
@@ -39,6 +39,7 @@ DOC_CONTENTS="
\nIf you are running systemd, you will need to review the instructions
explained in /etc/dict/dictd.conf comments.
"
+
PATCHES=(
"${FILESDIR}"/dictd-1.10.11-colorit-nopp-fix.patch
"${FILESDIR}"/dictd-1.12.0-build.patch
@@ -78,15 +79,15 @@ src_test() {
if [[ ${EUID} -eq 0 ]]; then
# If dictd is run as root user (-userpriv) it drops its privileges to
# dictd user and group. Give dictd group write access to test directory.
- chown :dictd "${WORKDIR}" "${S}/test"
- chmod 770 "${WORKDIR}" "${S}/test"
+ chown :dictd "${WORKDIR}" "${S}/test" || die
+ chmod 770 "${WORKDIR}" "${S}/test" || die
fi
emake test
}
src_install() {
if use minimal; then
- emake DESTDIR="${D}" install.dictzip install.dict install.dictfmt
+ emake DESTDIR="${ED}" install.dictzip install.dict install.dictfmt
else
default