summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 12:38:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:17:22 +0100
commite7be9f0f848c5583f619242e9444bcb3e59bbdfd (patch)
treee997d824576569e0e0758d85fff4633bb32f8b14 /app-text/xiphos
parentapp-text/sigil: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-e7be9f0f848c5583f619242e9444bcb3e59bbdfd.tar.gz
gentoo-e7be9f0f848c5583f619242e9444bcb3e59bbdfd.tar.bz2
gentoo-e7be9f0f848c5583f619242e9444bcb3e59bbdfd.zip
app-text/xiphos: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-text/xiphos')
-rw-r--r--app-text/xiphos/xiphos-4.0.6a-r2.ebuild (renamed from app-text/xiphos/xiphos-4.0.6a-r1.ebuild)14
-rw-r--r--app-text/xiphos/xiphos-4.1.0-r2.ebuild (renamed from app-text/xiphos/xiphos-4.1.0-r1.ebuild)14
2 files changed, 18 insertions, 10 deletions
diff --git a/app-text/xiphos/xiphos-4.0.6a-r1.ebuild b/app-text/xiphos/xiphos-4.0.6a-r2.ebuild
index c131ac2b16a7..4ca64d0c5aae 100644
--- a/app-text/xiphos/xiphos-4.0.6a-r1.ebuild
+++ b/app-text/xiphos/xiphos-4.0.6a-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,24 +21,28 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
>=app-text/sword-1.7.4
dev-libs/glib:2
- dev-libs/libxml2:2[${PYTHON_USEDEP}]
- gnome-base/gconf[${PYTHON_USEDEP}]
gnome-extra/gtkhtml:4.0
>=gnome-extra/libgsf-1.14
net-libs/webkit-gtk:4
x11-libs/gtk+:3
+ $(python_gen_cond_dep '
+ dev-libs/libxml2:2[${PYTHON_MULTI_USEDEP}]
+ gnome-base/gconf[${PYTHON_MULTI_USEDEP}]
+ ')
dbus? ( dev-libs/dbus-glib )
"
DEPEND="${RDEPEND}
app-text/docbook2X
- app-text/gnome-doc-utils[${PYTHON_USEDEP}]
app-text/rarian
- dev-libs/libxslt[${PYTHON_USEDEP}]
dev-util/intltool
dev-util/glib-utils
>=net-libs/biblesync-1.1.2-r1[-static]
virtual/pkgconfig
sys-devel/gettext
+ $(python_gen_cond_dep '
+ app-text/gnome-doc-utils[${PYTHON_MULTI_USEDEP}]
+ dev-libs/libxslt[${PYTHON_MULTI_USEDEP}]
+ ')
"
pkg_setup() {
diff --git a/app-text/xiphos/xiphos-4.1.0-r1.ebuild b/app-text/xiphos/xiphos-4.1.0-r2.ebuild
index 355ed3f118cb..159e9351269a 100644
--- a/app-text/xiphos/xiphos-4.1.0-r1.ebuild
+++ b/app-text/xiphos/xiphos-4.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,24 +19,28 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
>=app-text/sword-1.8.0
dev-libs/glib:2
- dev-libs/libxml2:2[${PYTHON_USEDEP}]
- gnome-base/gconf[${PYTHON_USEDEP}]
gnome-extra/gtkhtml:4.0
>=gnome-extra/libgsf-1.14
net-libs/webkit-gtk:4
x11-libs/gtk+:3
+ $(python_gen_cond_dep '
+ dev-libs/libxml2:2[${PYTHON_MULTI_USEDEP}]
+ gnome-base/gconf[${PYTHON_MULTI_USEDEP}]
+ ')
dbus? ( dev-libs/dbus-glib )
"
DEPEND="${RDEPEND}
app-text/docbook2X
- app-text/gnome-doc-utils[${PYTHON_USEDEP}]
app-text/rarian
- dev-libs/libxslt[${PYTHON_USEDEP}]
dev-util/glib-utils
dev-util/intltool
>=net-libs/biblesync-1.1.2-r1[-static]
virtual/pkgconfig
sys-devel/gettext
+ $(python_gen_cond_dep '
+ app-text/gnome-doc-utils[${PYTHON_MULTI_USEDEP}]
+ dev-libs/libxslt[${PYTHON_MULTI_USEDEP}]
+ ')
"
pkg_setup() {