summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/gconfmm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/gconfmm')
-rw-r--r--dev-cpp/gconfmm/Manifest1
-rw-r--r--dev-cpp/gconfmm/gconfmm-2.28.3.ebuild38
-rw-r--r--dev-cpp/gconfmm/metadata.xml5
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/gconfmm/Manifest b/dev-cpp/gconfmm/Manifest
new file mode 100644
index 000000000000..d4e406edca94
--- /dev/null
+++ b/dev-cpp/gconfmm/Manifest
@@ -0,0 +1 @@
+DIST gconfmm-2.28.3.tar.xz 376840 SHA256 d7bd2d29c1a87b85329547fb29a0eca52d944e60699982152775002e24c09228 SHA512 8a6f34b175fd2370d596ef859b7075140441f14b97b708afd96bae25874780d321ed81905182ed50abaf6f41f710a325b8053b9aef511cd242df43570646df73 WHIRLPOOL 452f600bb03670a09797ac43c547e7038c16f322f372dd1a4db9ec4a5646ecb4be40a69e2aa91aaa849a3211268d060bcca4b44a438c8c194261253d71d89bc5
diff --git a/dev-cpp/gconfmm/gconfmm-2.28.3.ebuild b/dev-cpp/gconfmm/gconfmm-2.28.3.ebuild
new file mode 100644
index 000000000000..8254053a5d9f
--- /dev/null
+++ b/dev-cpp/gconfmm/gconfmm-2.28.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for GConf"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=gnome-base/gconf-2.4:2
+ >=dev-cpp/glibmm-2.12:2[doc?]
+ >=dev-cpp/gtkmm-2.4:2.4"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS COPYING* ChangeLog NEWS README INSTALL"
+ G2CONF="${G2CONF}
+ $(use_enable doc documentation)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/*
+ fi
+}
diff --git a/dev-cpp/gconfmm/metadata.xml b/dev-cpp/gconfmm/metadata.xml
new file mode 100644
index 000000000000..57c9d9c1a1d8
--- /dev/null
+++ b/dev-cpp/gconfmm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-mm</herd>
+</pkgmetadata>