summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-19 19:00:57 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-08-26 01:53:41 +0200
commit69b9f1d9e9b7a8b52d5bd46090e5b025cd2364ae (patch)
tree011cd292d669bcd09dd90ffeccdaec88df4f0863 /dev-cpp/msgpack-cxx
parentsci-mathematics/mathmod: drop old (diff)
downloadgentoo-69b9f1d9e9b7a8b52d5bd46090e5b025cd2364ae.tar.gz
gentoo-69b9f1d9e9b7a8b52d5bd46090e5b025cd2364ae.tar.bz2
gentoo-69b9f1d9e9b7a8b52d5bd46090e5b025cd2364ae.zip
dev-cpp/msgpack-cxx: add 6.1.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/38207 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-cpp/msgpack-cxx')
-rw-r--r--dev-cpp/msgpack-cxx/Manifest1
-rw-r--r--dev-cpp/msgpack-cxx/msgpack-cxx-6.1.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-cpp/msgpack-cxx/Manifest b/dev-cpp/msgpack-cxx/Manifest
index ee0e3f82a9ec..6e465b95701d 100644
--- a/dev-cpp/msgpack-cxx/Manifest
+++ b/dev-cpp/msgpack-cxx/Manifest
@@ -1,3 +1,4 @@
DIST msgpack-cxx-5.0.0.tar.gz 476103 BLAKE2B e631a47e8d39b6ad9c2dd5e782fbbd5044c177e18c619fb52d1293e2c5f2ea7e766e7b26ce6cac36a2ff98217143e12456e0541992afb4f78597ffd3852f2acf SHA512 5ee0237eb1bf05bd4becad32ab145a8f0654f8f0e2e3452331ed3df088cda03ee4cdf1557ba867447e3e18baed924c105c76934f7009dac98b6dc69282c39d0c
DIST msgpack-cxx-6.0.0.tar.gz 476132 BLAKE2B 89b6505511bd8f6994a2e61661c7a33bd1aa68804c081ec2fcaf074f845caf4338ac362916af9fb0bab7285b0d0508c74b229316fa75ef8083546ac84c4ca95d SHA512 90f89216676af5a656d570fbff5a716d1177fa1941b0a928b2da20e0b6cd6d0ca880b7369e085dbbca944499c05694a73df919042d8cd78498ed4b34b77a0e9d
DIST msgpack-cxx-6.1.0.tar.gz 478452 BLAKE2B 14c6e28ab02957e6313a01002d05c23e2599f433656c8ea8033eb338c6e8b97d10e00a91e1e67bc3b944c3f9b46ad1ea11fc6905d50554699caeed7bd9cbc8f7 SHA512 935453432b53d2cbecc3e34d4fb17ecd3bbc6eae9087fa3c4445c90750f144ab39ad6461cc9552eec7ed2b222315c5f6e8b30d409eb34a98bebe02e03582fd41
+DIST msgpack-cxx-6.1.1.tar.gz 476459 BLAKE2B 6ec940af9b9e02d892c5f118791015baa6b12baa60c77aaf2ff867e8836f21b4f16c436ce448cdfeb7dc8f8a9356a75f3ac829eba9059ca5d78f42a4393700ff SHA512 6a3df977e7a9c8b50feb7c88cff7a78814d1d41d2f7a657dd37d6cfcfe24f44746f40a6dd46bd5dba7ea59d94b9e40c2baa62c08d9b02168ac93c58cbff3becc
diff --git a/dev-cpp/msgpack-cxx/msgpack-cxx-6.1.1.ebuild b/dev-cpp/msgpack-cxx/msgpack-cxx-6.1.1.ebuild
new file mode 100644
index 000000000000..62978b6f9fb4
--- /dev/null
+++ b/dev-cpp/msgpack-cxx/msgpack-cxx-6.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="MessagePack for C++"
+HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
+SRC_URI="https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+boost doc examples test"
+
+REQUIRED_USE="test? ( boost )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="boost? ( dev-libs/boost[context] )
+ !<dev-libs/msgpack-5.0.0"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-text/doxygen[dot] )
+ test? ( sys-libs/zlib )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMSGPACK_BUILD_EXAMPLES=OFF
+ -DMSGPACK_CXX17=ON
+ -DMSGPACK_BUILD_TESTS="$(usex test)"
+ -DMSGPACK_USE_BOOST="$(usex boost)"
+ -DMSGPACK_USE_X3_PARSE="$(usex boost)"
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc; then
+ cmake_build doxygen
+ fi
+}
+
+src_install() {
+ if use doc; then
+ local HTML_DOCS=( "${BUILD_DIR}"/doc_cpp/html/. )
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ cmake_src_install
+}